Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57325 - [racket] Malformed r6rs program crashes drracket

Attached to Project: Community Packages
Opened by Aaron L (ajlippev) - Thursday, 01 February 2018, 14:18 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 01 February 2018, 15:54 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
Malformed r6rs program crashes drracket.
Could not reproduce this bug on Ubuntu, neither with an in-place install on Arch install with the official linux installer (.sh).
A reinstall of the package does not fix the issue.

Additional info:
* racket version 6.12-1


Steps to reproduce:
Open drracket, set language to 'racket' and paste the following:

#lang r6rs
(import (rnrs base))
(define test (lambda ()))

Alternatively, save this as anything.rkt and try to open it with drracket.
The result is the same.

This task depends upon

Comment by Kyle Keen (keenerd) - Thursday, 01 February 2018, 16:44 GMT
Can reproduce. Interesting that it gives a SIGSEGV MAPERR with drracket and a trace with racket-minimal.

However this doesn't seem to be a new error. Our 6.11 package does the same thing.

If you'd like to help further debug, here are old versions:

https://archive.archlinux.org/packages/r/racket/

https://archive.archlinux.org/packages/r/racket-minimal/

I am by no means an expert with the internals of Racket, please continue investigating if you can.
Comment by Aaron L (ajlippev) - Thursday, 01 February 2018, 18:22 GMT
Yeah, I should have mentioned that I first came across it on 6.11.

It's a pretty weird thing. I'm guessing it's just some module it can't find.
I'll diff the install from the official installer and the package sometime and get back to you with the results.

Loading...