Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57310 - [radvd] Regression with special prefix "::/64" (upstream patch available)

Attached to Project: Community Packages
Opened by Thore Bödecker (foxxx0) - Wednesday, 31 January 2018, 12:36 GMT
Last edited by Thore Bödecker (foxxx0) - Saturday, 10 March 2018, 12:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Thore Bödecker (foxxx0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Within the last couple of releases there has been a regression in radvd regarding the special "::/64" prefix.
This special prefix is intended to instruct radvd to perform autodetection on the specified interface, allowing for dynamic prefixes without reconfiguration.



Additional info:
* package version: 2.17-1
* minimal config: https://paste.foxxx0.de/IOF/
* upstream fix (commit): https://github.com/reubenhwk/radvd/commit/b37baa1137d0bd5b9cceb2e447550f1c0a105ac6
* full patch (that commit unfortunately breaks one of the tests): https://paste.foxxx0.de/gyq/
* fixed PKGBUILD: https://paste.foxxx0.de/QqhDv/


Steps to reproduce:
* install radvd 2.17-1
* use the provided minimal config (maybe change the interface name)
* add some ipv6 /64 prefix to that interface (e.g. fc00::1/64, this is non-globally-routable prefix so it won't break connectivity while testing)
* restart radvd.service

Expected result:
radvd starts up and begins announcing that prefix on the configured interface

Actual result:
radvd refuses to start, error: invalid all-zeros prefix in /etc/radvd.conf, line 3
This task depends upon

Closed by  Thore Bödecker (foxxx0)
Saturday, 10 March 2018, 12:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed as of radvd-2.17-2

Loading...