Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#57281 - Boot failure of stock iso on Lenovo Miix 320

Attached to Project: Release Engineering
Opened by Christian Fahr (cfahr) - Monday, 29 January 2018, 21:35 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Tuesday, 30 January 2018, 06:50 GMT
Task Type Bug Report
Category Hardware Issues
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

How to reproduce:

- Download archlinux-2018.01.01-x86_64.iso (md5 1a9e79614527534105a40b2beb09f30f)
- Write it to USB and boot boot it on an Lenovo Miix 320.
- Launcher menu apppears.
- Try to boot.
- Watch your screen turn black. :/

I think this is related to https://bugs.freedesktop.org/show_bug.cgi?id=96571
If I am right, this is a conflict of i915 probing things before the backlight pwm driver
is ready. I might be totally wrong, though.
The current ubuntu image is working, I think they delay i915 till things are ready at the
expense of some garbled output at the beginning of startup.
The right place to fix this would be in the driver, but this didnt happen for some time.
A workaround would be to delay i915 in the initramfs.
I did try to start with rd.driver.blacklist=i915. This did NOT work for me.
This prevents installing arch with the iso.
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Tuesday, 30 January 2018, 06:50 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Nothing to do here. Please use forums to support request. Anyways, rd.driver.blacklist is for Dracut (Fedora/CentOS). Use nomodeset instead.

Loading...