Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57280 - [diffoscope] Empty man page

Attached to Project: Community Packages
Opened by Victor Engmark (l0b0) - Monday, 29 January 2018, 21:06 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 30 January 2018, 04:24 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: `man diffoscope` shows an empty man page.


Additional info:
* package versions: diffoscope 90-1, man-db 2.7.6.1-3


Steps to reproduce:
1. Install diffoscope
1. Run `man diffoscope` (without the backticks)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 30 January 2018, 04:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  diffoscope 90-2
Comment by Eli Schwartz (eschwartz) - Monday, 29 January 2018, 21:36 GMT
requires help2man and rst2man during build(), and the Makefile does not exit with an error if they're not available.

This is due to using pipelines without pipefail, which is not guaranteed to exist anyway unless you actually use `SHELL = /bin/bash` in your Makefile.
Comment by Victor Engmark (l0b0) - Tuesday, 30 January 2018, 01:01 GMT
I've installed both via the help2man and python-docutils packages (and verified that both commands were available), but after a `sudo pacman --sync diffoscope` the symptoms persist. Ditto after `sudo pacman --remove diffoscope && sudo pacman --sync diffoscope`.
Comment by Eli Schwartz (eschwartz) - Tuesday, 30 January 2018, 01:27 GMT
I, um, don't quite understand why you think that would help? My comment was a reference to the package maintainer, regarding the necessary steps for making the source code properly create the man page. Are you downloading the diffoscope source code and trying to repackage the software?

tl;dr
If you don't understand what something is referring to, blindly installing software won't help. If your intent was to fork the repository package and rebuild it with local modifications so you will have the manpage while waiting for this bug to be fixed, then you have forgotten the final step: https://wiki.archlinux.org/index.php/Arch_Build_System#Why_would_I_want_to_use_ABS.3F
Comment by Victor Engmark (l0b0) - Tuesday, 30 January 2018, 01:51 GMT
I thought "requires help2man and rst2man during build(), and the Makefile does not exit with an error if they're not available" meant that if I had those available they would be used by the current build script, and that the rest was simply instructions to help the package maintainer modify the build script to fail if they are not available. No problem, I'll keep my hands off.
Comment by Eli Schwartz (eschwartz) - Tuesday, 30 January 2018, 02:13 GMT
Yes, the build script is run by the package maintainer. ;)

Loading...