Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57259 - [gtk-xfce-engine] GTK+ 3 themes

Attached to Project: Arch Linux
Opened by Marcos Mello (marcosfrm) - Sunday, 28 January 2018, 16:34 GMT
Last edited by Jan de Groot (JGC) - Sunday, 28 January 2018, 21:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Current gtk-xfce-engine package only has GTK+ 2 themes. We already have GTK+ 3 XFCE components in the repository, like xfce4-pulseaudio-plugin, xfce4-power-manager, xfce4-terminal, mousepad, and so on. This results in inconsistent theming between GTK+ 2 and GTK+ 3 programs.

gtk-xfce-engine 3.x.x can be configured to install both theme types with --enable-gtk3 AFAIK.

Looking at git log, 2.99.0-2 had split packages for GTK+ 2/GTK+ 3 themes. Then it was downgraded to 2.10.0, the split packages were unified and GTK+ 3 themes dropped...

At this point, with XFCE 4.14 fully GTK+ 3 approaching, we should be shipping GTK+ 3 themes, no?
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 28 January 2018, 21:26 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Sunday, 28 January 2018, 19:17 GMT
gtk-xfce-engine is unmaintained upstream. The gtk3 themes are marked as "doesn't work with gtk 3.4", so there's no use even trying to package this.
Comment by Marcos Mello (marcosfrm) - Sunday, 28 January 2018, 20:43 GMT
Thanks for the information. I think we need to wait for XFCE 4.14 then.

Loading...