Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57242 - [owncloud-client] Integration with gnome-keyring requires libgnome-keyring

Attached to Project: Community Packages
Opened by Luis von Bernus (PaterSiul) - Saturday, 27 January 2018, 10:03 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 27 January 2018, 11:30 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When running owncloud-client without having libgnome-keyring installed, it asks for your password at every start with the message "Reading from keychain failed with error: 'No keychain service available'".

After installing libgnome-keyring as per https://github.com/owncloud/client/issues/1590#issuecomment-333116629, owncloud-client saved and retrieved the password in/from gnome-keyring.

Additional info:
* owncloud-client version 2.4.0-1
* qtkeychain version 0.8.0-2
* gnome-keyring version 1:3.27.2-1
* libsecret version 0.18.5+14+g9980655-1
* libgnome-keyring version 3.12.0-2

Steps to reproduce:
Running owncloud-client in gnome-shell without having libgnome-keyring installed/after removing libgnome-keyring.
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 27 January 2018, 11:30 GMT
Reason for closing:  Not a bug
Additional comments about closing:  it's an optdepend of qtkeychain

Loading...