Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57236 - [libasl] Doesn't build with out netcdf

Attached to Project: Community Packages
Opened by Andreas Baumann (andreas_baumann) - Friday, 26 January 2018, 21:05 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 26 January 2018, 23:29 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Evgeniy Alexeev (arcan1s)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

building libasl I get:

make[2]: *** No rule to make target '/usr/lib/libnetcdf.so', needed by 'src/libaslvtk.so.0.1.7'. Stop.
make[1]: *** [CMakeFiles/Makefile2:177: src/CMakeFiles/aslvtk.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

When installing libnetcdf by hand into the build chroot, it works.

In PKGBUILD of vtk I see a makedepends and an optdepends for libnetcdf.
So libnetcdf gets installed into the chroot due to the make dependency
and then creeps up into vtk as a library dependency.

Does vtk build without libnetcdf? then an optdepends would suffice.
Or is it a requirement, then in should be in depends IMHO.

Additional info:
* package version(s): 8.1.0-2
* config and/or log files etc.

vtk: 8.1.0-2
libasl: 0.1.7-10

Steps to reproduce:
asp export libasl
cd libasl
makepkg -s
This task depends upon

Comment by Evgeniy Alexeev (arcan1s) - Monday, 29 January 2018, 11:18 GMT
vtk=8.1.0-2 was rebuild against system netcdf whereas libasl was build only with vtk=8.1.0-1. That caused the issue.

About vtk opt and make dependencies I will reconsider it a bit later, I believe currently it supposes to be run on "minimal" features list, but more likely it wont work at all in common cases
Comment by Evangelos Foutras (foutrelis) - Thursday, 31 May 2018, 13:50 GMT
This is breaking rebuilds of libasl; maybe the dependency on netcdf shouldn't be optional?

Loading...