Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57209 - [librsvg] Massive slowdown since 2.41.2

Attached to Project: Arch Linux
Opened by Felipe Contreras (felipec) - Tuesday, 23 January 2018, 20:07 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 23 January 2018, 20:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I debugged a massive slowdown I experienced on my system, and eventually found the culprit: librsvg 2.41.2.

The slowness is easy to reproduce using the FlatWoken icon theme: https://github.com/alecive/FlatWoken.

I tried to bisect the issue, and the issue started because the developers decided to rewrite librsvg in Rust. So from 2.41.0 the code has become slower and slower.

I contacted the developers, and as typical GNOME developers they don't seem particularly worried about regressions caused by their rewrite.

https://gitlab.gnome.org/GNOME/librsvg/issues/188

My suggestion is to stick with 2.40.x. Unfortunately it seems a fork might be needed.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 23 January 2018, 20:15 GMT
Reason for closing:  Upstream
Additional comments about closing:  2.41.x is what upstream supports. We won't revert to 2.40 unless we hit severe rendering bugs or compatibility problems.

Loading...