Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57153 - [gnome-control-center] Segfault when clicking some search results after update to glib2-2.54.3

Attached to Project: Arch Linux
Opened by Joonas Henriksson (ooo) - Friday, 19 January 2018, 09:07 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 25 March 2018, 03:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
gnome-control-center exits with a segmentation fault, when you search for settings panel, and select certain search results. Seems like this is another issue caused by glib2-2.54.3 update

Selecting at least the following search results result in segfault:
-Keyboard
-Mouse & Touchpad
-Display
-Removable Media
-Wacom Tablet
-Color
(i.e. everything in Devices submenu, apart from Printers)

Searching and selecting any other panel apart from the aforementioned seem to work.


Additional info:
Tested with gnome-control-center-3.26.2+14+g5ac6a0da6-1

The issue appeared after update to glib2-2.54.3-1.
After downgrading back to glib2-2.54.2-2, there are no segfaults and everything seems to work.

glib2-2.54.3-2 doesn't fix the issue.
I also tested glib2-2.54.3+2+g94b38beff-1 currently on [testing], but the problem persists.

Here's the forum thread where this issue was reported: https://bbs.archlinux.org/viewtopic.php?id=233541


Steps to reproduce:
1. Click the search button on upper left corner.
2. Search for "keyboard"
3. Select "Keyboard" from search results with mouse or keyboard.
4. gnome-control-center exits with no error message other than "Segmentation fault (core dumped)"
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 25 March 2018, 03:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.28.0
Comment by Jan Alexander Steffens (heftig) - Friday, 19 January 2018, 20:27 GMT
Can't reproduce.
Comment by Joonas Henriksson (ooo) - Monday, 22 January 2018, 16:51 GMT
Upon further investigation I found out I can't reproduce this with a newly created user, and I'm yet to figure out what in my old user's configuration is triggering the bug.
Comment by Joonas Henriksson (ooo) - Monday, 22 January 2018, 17:09 GMT
EDIT. Double poist, sorry I don't know how that happened.

Loading...