Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57138 - [nodejs] [libuv] NPM socket error

Attached to Project: Arch Linux
Opened by Rc (fasterday) - Thursday, 18 January 2018, 07:43 GMT
Last edited by Felix Yan (felixonmars) - Friday, 19 January 2018, 04:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
NPM (Node package manager) does not seem to work anymore with libuv version 1.19.0-1

Additional info:
* NPM version : 5.6.0

npm ERR! code ENOTCONN
npm ERR! errno ENOTCONN
npm ERR! syscall read
npm ERR! read ENOTCONN
npm ERR! code ENOTCONN
npm ERR! errno ENOTCONN
npm ERR! syscall read
npm ERR! read ENOTCONN


Steps to reproduce:
Run command "npm install"
This task depends upon

Closed by  Felix Yan (felixonmars)
Friday, 19 January 2018, 04:44 GMT
Reason for closing:  Fixed
Additional comments about closing:  libuv 1.19.0-2
Comment by Alex (nylocx) - Thursday, 18 January 2018, 08:28 GMT
I can confirm that downgrading to libuv-1.18.0-1 resolves the issue.
Comment by Deepak (deepakjois) - Thursday, 18 January 2018, 12:59 GMT
I can confirm this bug too. npm, the node.js package manager started giving me ENOTCONN errors after upgrading to this.
Comment by Eli Schwartz (eschwartz) - Thursday, 18 January 2018, 13:06 GMT
Works fine for me, so you're gonna have to provide more details than that. What are the complete error messages, for example?
Comment by Deepak (deepakjois) - Thursday, 18 January 2018, 13:09 GMT
Actually, this is a legitimate issue with the latest version of libuv. They are aware of it:

* https://github.com/libuv/libuv/issues/1716
Comment by Deepak (deepakjois) - Thursday, 18 January 2018, 13:20 GMT
If you are looking to reproduce it, try running:

`npm install sharp`
Comment by Eli Schwartz (eschwartz) - Thursday, 18 January 2018, 13:38 GMT
  • Field changed: Summary ([libuv] NPM socket error → [nodejs] [libuv] NPM socket error)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Architecture (x86_64 → All)
  • Task assigned to Felix Yan (felixonmars)
Ah, that package seems to cause issues.

```
[builduser@eschwartz ~]$ npm install sharp

> sharp@0.19.0 install /build/node_modules/sharp
> node-gyp rebuild

gyp ERR! UNCAUGHT EXCEPTION
gyp ERR! stack Error: read ENOTCONN
gyp ERR! stack at _errnoException (util.js:1003:13)
gyp ERR! stack at Socket._read (net.js:495:20)
gyp ERR! stack at Socket.Readable.read (_stream_readable.js:449:10)
gyp ERR! stack at Socket.read (net.js:376:43)
gyp ERR! stack at new Socket (net.js:259:12)
gyp ERR! stack at createSocket (internal/child_process.js:241:11)
gyp ERR! stack at ChildProcess.spawn (internal/child_process.js:357:23)
gyp ERR! stack at exports.spawn (child_process.js:499:9)
gyp ERR! stack at PythonFinder.exports.execFile (child_process.js:209:15)
gyp ERR! stack at PythonFinder.checkPythonVersion (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:446:10)
gyp ERR! System Linux 4.14.12-1-ARCH
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
```
Comment by Felix Yan (felixonmars) - Thursday, 18 January 2018, 18:16 GMT
Please try again with libuv 1.19.0-2.
Comment by Rc (fasterday) - Thursday, 18 January 2018, 18:44 GMT
I can confirm that the bug is fixed with libuv 1.19.0-2
Thanks for the responsiveness!

Loading...