Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57118 - [gajim] should optdepend on python2-pygments

Attached to Project: Arch Linux
Opened by Markus Pesch (volker.raschek) - Tuesday, 16 January 2018, 16:58 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 16 January 2018, 20:16 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Eric Belanger (Snowman)
Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Hello,
i have installed python-pygments and use it for syntax highlithing.

I wanted to activate the addon source code syntax highlight of the jabber client gajim. Unfortunately the activation of the addon is missing because pygments is not found.

On request from the developers of Gajim, why it comes to the problem, a possible difference between the packaging between Debian and Arch-Linux was assumed and I should forward the error to the maintainers of the packaging of pygments.

Issue on Gajim: https://dev.gajim.org/gajim/gajim-plugins/issues/242

Additional info:
* package version(s)
* Pygments version 2.2.0

* config and/or log files etc.


Steps to reproduce:


https://dev.gajim.org/gajim/gajim-plugins/issues/242
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 16 January 2018, 20:16 GMT
Reason for closing:  Not a bug
Comment by Markus Pesch (volker.raschek) - Tuesday, 16 January 2018, 17:01 GMT
How I can edit my post ? -.-'
I sent the post to early.
Comment by Eli Schwartz (eschwartz) - Tuesday, 16 January 2018, 17:18 GMT
  • Field changed: Attached to Project (Community Packages → Arch Linux)
  • Field changed: Task Type (Support Request → Bug Report)
  • Field changed: Summary ([python-pygments] PLEASE ENTER SUMMARY → [gajim] should optdepend on python2-pygments)
  • Field changed: Architecture (x86_64 → All)
  • Task assigned to Antonio Rojas (arojas), Eric Belanger (Snowman)
the bugreport is against gajim, not against our pygments package.

And Arch Linux defaults to python3, you need to specify the python2-pygments package. pygmentize is only the /usr/bin/ tool, not the python module.

This should be added as an optdepends I guess.
Comment by Antonio Rojas (arojas) - Tuesday, 16 January 2018, 20:16 GMT
The syntax highlight plugin is a third-party plugin not included in our package.

Loading...