Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57100 - [glib2] This package requires python-codegen [AUR] to work

Attached to Project: Arch Linux
Opened by Alejandro Perez (alejandro.perez) - Monday, 15 January 2018, 07:09 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 15 January 2018, 07:39 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
/usr/sbin/gdbus-codegen requires having the "codegen" python package installed. Description seems indicating that it is provided by the standard "python" package, but it seems is not the case anymore:

$ python -c "import codegen"
Traceback (most recent call last):
File "<string>", line 1, in <module>
ModuleNotFoundError: No module named 'codegen'

There is a package in AUR called python-codegen that seems to provide it, but since this is a [core] package, it should not depend on AUR packages IMO.

Steps to reproduce:
Just execute "/usr/sbin/gdbus-codegen" without having python-codegen installed.

$ gdbus-codegen
Traceback (most recent call last):
File "/usr/sbin/gdbus-codegen", line 41, in <module>
from codegen import codegen_main
ModuleNotFoundError: No module named 'codegen'
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 15 January 2018, 07:39 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#55915 
Comment by Chih-Hsuan Yen (yan12125) - Monday, 15 January 2018, 07:28 GMT

Loading...