Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57069 - [maude] needs rebuild after cvc4 1.5-1 update

Attached to Project: Community Packages
Opened by Gurb (gurb) - Friday, 12 January 2018, 12:08 GMT
Last edited by Antonio Rojas (arojas) - Friday, 12 January 2018, 19:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The package maude depends on cvc4. After cvc4's 1.5-1 update, maude cannot be run because libcvc4 is not found as its name has changed from libcvc4.so.3 to libcvc4.so.4.

Maude 2.7.1-1 can still be built from source with the new version of cvc4.

Steps to reproduce:

1. Install maude package.
2. Run maude command. The following will be shown:
maude: error while loading shared libraries: libcvc4.so.3: cannot open shared object file: No such file or directory
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 12 January 2018, 19:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  maude 2.7.1-2

Loading...