Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57062 - [texlive-bin] [poppler] SIGABRT at end of pdflatex compilation

Attached to Project: Arch Linux
Opened by T. Fischer (thfischer) - Friday, 12 January 2018, 08:54 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 19 January 2018, 16:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I have bug which is very similar to task 55720, maybe it is the same as 55720 was never properly fixed.
I have a large LaTeX document (200+ pages) with some images, TikZ stuff, minted for source code etc.
At the very end of a pdflatex run, I get the following output:

[...]
Output written on xxxx.pdf
pdflatex: ../nptl/pthread_mutex_lock.c:427: __pthread_mutex_lock_full: Assertion `INTERNAL_SYSCALL_ERRNO (e, __err) != ESRCH || !robust' failed.
Program received signal SIGABRT, Aborted.
0x00007ffff6667860 in raise () from /usr/lib/libc.so.6

To get more information, I ran pdflatex in gdb and got the following backtrace:

#0 0x00007ffff6667860 in raise () from /usr/lib/libc.so.6
#1 0x00007ffff6668ec9 in abort () from /usr/lib/libc.so.6
#2 0x00007ffff66600bc in __assert_fail_base () from /usr/lib/libc.so.6
#3 0x00007ffff6660133 in __assert_fail () from /usr/lib/libc.so.6
#4 0x00007ffff4b5a992 in __pthread_mutex_lock_full () from /usr/lib/libpthread.so.0
#5 0x00007ffff75e48d4 in Dict::decRef() () from /usr/lib/libpoppler.so.72
#6 0x00007ffff764c78a in Object::free() () from /usr/lib/libpoppler.so.72
#7 0x00007ffff764f825 in PageAttrs::~PageAttrs() () from /usr/lib/libpoppler.so.72
#8 0x00007ffff7650a6b in Page::~Page() () from /usr/lib/libpoppler.so.72
#9 0x00007ffff75d7e1a in Catalog::~Catalog() () from /usr/lib/libpoppler.so.72
#10 0x00007ffff76568be in PDFDoc::~PDFDoc() () from /usr/lib/libpoppler.so.72
#11 0x00005555555eccac in delete_document(PdfDocument*) ()
#12 0x00005555555f06a9 in epdf_check_mem ()
#13 0x00005555555d68bf in libpdffinish ()
#14 0x0000555555588136 in closefilesandterminate ()
#15 0x000055555557bb25 in mainbody ()
#16 0x0000555555566a8f in main ()

Compilation succeeds if I disable some sections of the document. But that doesn't help me, I need the full document, of course.

I tried the packages as provided at https://pkgbuild.com/~remy/texlive-experimental/ by Rémy Oudompheng for  bug 55720 , but those won't work any longer as Arch uses a newer Poppler library now, so pdflatex won't start due to incompatible shared objects/libraries.

My currently installed relevant packages are as follows:

extra/poppler 0.61.1-1
(and some more matching Poppler packages)
extra/texlive-core 2017.45811-1
extra/texlive-bin 2017.44590-9
community/biber 2.10-1
This task depends upon

Comment by Rémy Oudompheng (remyoudompheng) - Friday, 19 January 2018, 20:43 GMT
Can you please provide a sample document ?
Preferably without the full 200 pages. You can send it by email if it doesn't fit here.

Thanks.
Comment by Rémy Oudompheng (remyoudompheng) - Friday, 19 January 2018, 21:01 GMT
Upstream has a slightly tweaked version of the patch that avoids the double-free issue.
I will try integrating it.

Loading...