Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57028 - [xf86-input-libinput] Without keyboard in Lenovo V310, suddenly

Attached to Project: Arch Linux
Opened by Maxwell Draven (Ravenman) - Tuesday, 09 January 2018, 16:25 GMT
Last edited by Laurent Carlier (lordheavy) - Monday, 21 May 2018, 07:26 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

I am working in KDE and I can not have write nothing (and the lock screen option neither works) suddenly, but the mouse pad continues working.

Checking the Xorg.0.log, I found these messages:

[ 5112.391] (II) event0 - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
[ 5112.391] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
[ 5112.391] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device removed

[ 5112.842] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device removed

Additional info:
* package version(s)

xorg-server 1.19.6-2
xf86-input-evdev 2.10.5-1
xf86-input-libinput 0.26.0-1
kde-meta 17.12-1
plasma-meta 5.11-1

* config and/or log files etc.

I am attaching the Xorg.0.log file.

Steps to reproduce:

Install KDE on Lenovo V310 laptop.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Monday, 21 May 2018, 07:26 GMT
Reason for closing:  No response
Comment by Doug Newgard (Scimmia) - Wednesday, 10 January 2018, 05:55 GMT
Duplicate of  FS#56996 ?
Comment by Maxwell Draven (Ravenman) - Wednesday, 10 January 2018, 20:30 GMT
@Scimmia No, this situation is very different because the keyboard works perfectly at beginning and almost all the time, but the keyboard fails suddenly only in KDE: if I change right away to a tty console, the keyboard continues working fine.
Comment by Andreas Radke (AndyRTR) - Thursday, 18 January 2018, 16:13 GMT
Please report it upsream.
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 13:02 GMT
This should be fixed with recent libinput and xf86-input-libinput updates.

Loading...