Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57009 - kontact crash

Attached to Project: Arch Linux
Opened by Munzir Taha (munzirtaha) - Monday, 08 January 2018, 15:13 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 08 January 2018, 16:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
kontact and its family (kmail, akregator, ...) all crashes and segfaults upon start and not usable any more.


Additional info:
* package version(s): 17.12.0-1
* config and/or log files etc.


Steps to reproduce:
@spectre~> kontact
[0108/180946.452166:WARNING:stack_trace_posix.cc(648)] Failed to open file: /home/munzir/#23471569 (deleted)
Error: No such file or directory
[3440:3463:0108/180946.541899:ERROR:gl_implementation.cc(246)] Failed to load /usr/bin/libGLESv2.so: /usr/bin/libGLESv2.so: cannot open shared object file: No such file or directory
"https://dot.kde.org/rss.xml"
"https://www.linux.com/feeds/rss"
"http://planetkde.org/rss20.xml"
"https://store.kde.org/content.rdf"
[3440:3463:0108/180947.673603:ERROR:gl_surface_qt.cpp(701)] Requested OpenGL implementation is not supported. Implementation: 0
*** stack smashing detected ***: <unknown> terminated
Received signal 6
#0 0x7fad34865086 <unknown>
#1 0x7fad334911cc <unknown>
#2 0x7fad348653fc <unknown>
#3 0x7fad43aca8e0 <unknown>
#4 0x7fad43aca860 __GI_raise
#5 0x7fad43acbec9 __GI_abort
#6 0x7fad43b0d437 __libc_message
#7 0x7fad43b9d33f __GI___fortify_fail_abort
#8 0x7fad43b9d302 __stack_chk_fail_local
#9 0x7fad334e777c <unknown>
#10 0x7fad352bada7 <unknown>
#11 0x7fad352c7e1e <unknown>
#12 0x7fad352ca6ff <unknown>
#13 0x7fad352cb96f <unknown>
#14 0x7fad352c52cd <unknown>
#15 0x7fad352c59e8 <unknown>
#16 0x7fad352c4bde <unknown>
#17 0x7fad352c7095 <unknown>
#18 0x7fad348eaee2 <unknown>
#19 0x7fad34882548 <unknown>
#20 0x7fad34883528 <unknown>
#21 0x7fad34883993 <unknown>
#22 0x7fad34884cf1 <unknown>
#23 0x7fad348a322b <unknown>
#24 0x7fad348be1f6 <unknown>
#25 0x7fad348b93eb <unknown>
#26 0x7fad3fa8b08c start_thread
#27 0x7fad43b8be1f __GI___clone
r8: 0000000000000000 r9: 00007face8ff7730 r10: 0000000000000008 r11: 0000000000000246
r12: 00007face8ff79d0 r13: 0000000000001000 r14: 0000000000000000 r15: 0000000000000030
di: 0000000000000002 si: 00007face8ff7730 bp: 00007face8ff7b60 bx: 0000000000000006
dx: 0000000000000000 ax: 0000000000000000 cx: 00007fad43aca860 sp: 00007face8ff7730
ip: 00007fad43aca860 efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000
trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000
[end of stack trace]
Calling _exit(1). Core file will not be generated.
[3486:3486:0100/000000.721328:ERROR:broker_posix.cc(43)] Invalid node channel message
[3488:3488:0100/000000.721290:ERROR:broker_posix.cc(43)] Invalid node channel message
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 08 January 2018, 16:06 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#56993 

Screw it, with no info given, we're going to make assumptions
Comment by Doug Newgard (Scimmia) - Monday, 08 January 2018, 15:21 GMT
Looks like your opengl setup is screwed up. Or maybe your linker path. What drivers and what settings?
Comment by Yannick Alméras (alfazaz) - Monday, 08 January 2018, 15:33 GMT
Same thing for me.

To "solve" the problem, I downgraded nvidia and nvidia-utils...
Comment by Munzir Taha (munzirtaha) - Monday, 08 January 2018, 15:50 GMT
~> sudo lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
00:13.0 Non-VGA unclassified device: Intel Corporation Sunrise Point-LP Integrated Sensor Hub (rev 21)
01:00.0 3D controller: NVIDIA Corporation GM108M [GeForce 940MX] (rev ff)


Attached is the output of journalctl -b -perr and pacman -Q

Comment by ads (flv) - Monday, 08 January 2018, 15:51 GMT
Seems related to : https://bugs.archlinux.org/task/56993

The new nvidia-utils should fix the issue
Comment by Doug Newgard (Scimmia) - Monday, 08 January 2018, 15:58 GMT
Possibly, but since neither poster answered by question, who knows.

Loading...