Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56898 - {namcap} git version crashes (shared-mime-info)

Attached to Project: Arch Linux
Opened by Michael (MST) - Friday, 29 December 2017, 18:17 GMT
Last edited by Kyle Keen (keenerd) - Sunday, 23 June 2019, 12:37 GMT
Task Type Bug Report
Category Arch Projects
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Running namcap-git f73bf160de19e43d1c22a3db0f32b234b872963f against traverso-0.49.5-1 [1],
fails.

traverso W: Referenced library 'liblilv-0.so.0' is an uninstalled dependency
Traceback (most recent call last):
File "/usr/lib/python3.6/runpy.py", line 193, in _run_module_as_main
"__main__", mod_spec)
File "/usr/lib/python3.6/runpy.py", line 85, in _run_code
exec(code, run_globals)
File "/home/michi/git/namcap/namcap.py", line 250, in <module>
process_realpackage(package, active_modules)
File "/home/michi/git/namcap/namcap.py", line 115, in process_realpackage
errs, warns, infos = Namcap.depends.analyze_depends(pkginfo)
File "/home/michi/git/namcap/Namcap/depends.py", line 123, in analyze_depends
reason_strings = [Namcap.tags.format_message(reason) for reason in reasons]
File "/home/michi/git/namcap/Namcap/depends.py", line 123, in <listcomp>
reason_strings = [Namcap.tags.format_message(reason) for reason in reasons]
File "/home/michi/git/namcap/Namcap/tags.py", line 55, in format_message
return (tags[tag] % data)
KeyError: 'shared-mime-info-needed'


Additional info:
No error with namcap-3.2.7, seems it was introduced with [2] (first commit after tag 3.2.7).


[1] https://aur.archlinux.org/packages/traverso/
[2] https://git.archlinux.org/namcap.git/commit/?id=e385ac93a3544acba464ca9d6ea738c19f7e0fc5
This task depends upon

Closed by  Kyle Keen (keenerd)
Sunday, 23 June 2019, 12:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  git commit ec3c111
Comment by Doug Newgard (Scimmia) - Friday, 05 January 2018, 08:13 GMT
ping keenerd
Comment by Xiretza (xiretza) - Friday, 24 August 2018, 13:43 GMT
this is happening with current osu-lazer-git [1] as well. It's really just a missing error message, not sure if it ever existed though.

[1] https://aur.archlinux.org/packages/osu-lazer-git/
Comment by (arisinfenix) - Sunday, 02 December 2018, 18:35 GMT Comment by Eli Schwartz (eschwartz) - Thursday, 11 April 2019, 01:24 GMT
I've submitted an alternative patch that removes this entirely. https://lists.archlinux.org/pipermail/arch-projects/2019-April/005203.html

Loading...