Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56849 - [ghostscript] Some files are not properly rendered

Attached to Project: Arch Linux
Opened by Olivier (olive) - Sunday, 24 December 2017, 21:40 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 27 December 2017, 06:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Some files are not properly rendered with the shipped ghostscript. I attach a test files where some symbols are missing. I have a file that get completely screwed up but unfortunately I can't attach it (it's a train ticket).

A vanilla build of ghostscript have none of these problems. By vanilla build, I have commented out all the "rm" I have seen in the PKGBUILD.


Additional info:
* package version(s)

9.22-4

* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 27 December 2017, 06:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  9.22-6
Comment by Jan Alexander Steffens (heftig) - Monday, 25 December 2017, 23:11 GMT
Sad that we can't use the OTF gsfonts.
Comment by Olivier (olive) - Tuesday, 26 December 2017, 13:03 GMT
There are still problems with some files. In order to have it work properly; I needed to keep the original fonts shipped with ghostscript AND to remove the line:

# force it to use system-libs
rm -r ...

A complete vanilla build with the original fonts and the provided libs works perfectly though. An alteration of one of these things leads to problems with some files.

The test following test file is a used train ticket:

-*snip*- (thanks. --heftig)

Due to the nature of the file; I am reluctant to post it permanently on the Archlinux bug reporting platform.
Comment by Jan Alexander Steffens (heftig) - Tuesday, 26 December 2017, 15:11 GMT
Actually, seems edited comments are kept in history in both versions, whoops. You can delete the file now, thanks.

Loading...