Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56815 - [lightdm] 1:1.24.0-2 service fila to start after packaging changes

Attached to Project: Arch Linux
Opened by loqs (loqs) - Thursday, 21 December 2017, 21:48 GMT
Last edited by Maxime Gauduin (Alucryd) - Saturday, 23 December 2017, 10:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The following change in lightdm.tmpfiles appears to prevent lightdm.service from starting
-d /run/lightdm 0711 lightdm lightdm
+d /run/lightdm 0711 root lightdm 0
Changing the user from root back to lightdm allowed lightdm.service to start without error

Additional info:
lightdm.sysusers
+g lightdm 620 -
+u lightdm 620 "Light Display Manager" /var/lib/lightdm
Creates a group first that would be created by the user line if the group was not just created.

lightdm.tmpfiles
+d /var/lib/lightdm 0770 lightdm lightdm -
+d /var/lib/lightdm-data 0770 lightdm lightdm -
switching the mode of the above from 1770 to 0770 caused still allowed lightdm to start without error while experimenting with the cause.

lightdm.log.old is the log produced from 1:1.24.0-2
lightdm.log is after making the first change to lightdm.tmpfiles

Steps to reproduce:
Upgrade to lightdm 1:1.24.0-2 use default config with lightdm-gtk-greeter and its default config
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Saturday, 23 December 2017, 10:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  1:1.24.0-3
Comment by Bjoern Franke (bjo) - Friday, 22 December 2017, 23:07 GMT
Yep, I also had this issues on two systems.
Comment by loqs (loqs) - Friday, 22 December 2017, 23:55 GMT
@bjo did changing the first line in /usr/lib/tmpfiles.d/lightdm.conf to d /run/lightdm 0711 lightdm lightdm 0 fix the issue on your systems?
Comment by Clemmitt Sigler (cmsigler) - Saturday, 23 December 2017, 02:32 GMT
Confirmed, same version upgrade, same problem. I changed the first line of /usr/lib/tmpfiles.d/lightdm.conf to this:

-- Cut here --
d /run/lightdm 0711 lightdm lightdm 0
-- Cut here --

and also did a `sudo chown lightdm /run/lightdm'. Then lightdm finally started correctly. HTH

Clemmitt Sigler
Comment by Maxime Gauduin (Alucryd) - Saturday, 23 December 2017, 10:44 GMT
Hmm, works fine here with all defaults as well. That directory should be deleted and recreated on every reboot because it's age is 0, and the documentation says the mode is changed if the directory exists (from an earlier installation where it's age was infinite). I'll change it back to "lightdm" while I investigate so people don't run into the same issue.

The /var/lib directories have always been 1770 because this package was initially largely inspired by gdm which does that. I also noticed 0770 should be enough last time I tried, I may switch in a future version.

As for the group, yes it will be created even without the line, but with a random gid, the point is to have a fixed gid here.

Loading...