Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56781 - [veracrypt] Option --fs-options=utf8=no now required

Attached to Project: Community Packages
Opened by Musikolo (Musikolo) - Wednesday, 20 December 2017, 00:27 GMT
Last edited by Levente Polyak (anthraxx) - Thursday, 21 December 2017, 08:45 GMT
Task Type Support Request
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I've noticed today that mounting a FAT32 volume I have, veracrypt now requires the option --fs-options=utf8=no to show all characters correctly. I'm 100% positive, I've changed nothing in the volume at all (for months). My volume is encoded with iso8859-1 charset.

If I issue "mount" in a console I get:

/dev/mapper/veracrypt1 on /home/musikolo/stuff type vfat (rw,relatime,uid=1000,gid=100,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,uft8,errors=remount-ro)

when I pass the abovementioned switch "--fs-options=utf8=no", the mount point looks like:
/dev/mapper/veracrypt1 on /home/musikolo/stuff type vfat (rw,relatime,uid=1000,gid=100,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)

which shows all characters correctly.

In an attempt to find out the root cause, I've tried rolling back my Linux kernel from 4.14.6 to 4.14.5, same as all the packages I upgraded within the last 3 days (from 18th back to 15th). Unfortunately, the issue was still there. I could not roll back more days, because I recently upgraded my to plasma 17.12, and there are too many packages (14th). You can see all the packages I've recently upgraded at https://pastebin.com/g6H3Lcmf

It took my a long while to figure out how to workaround the issue, but I would like to know the root cause of it.

Any clue on what could have changed the previous behavior?

More info - using:
veracrypt 1.21-2
fuse-common 3.2.1-1 (also tried with 3.2.0-1)
linux 4.14.6 (also tried with 4.14.5)
This task depends upon

Closed by  Levente Polyak (anthraxx)
Thursday, 21 December 2017, 08:45 GMT
Reason for closing:  Not a bug
Comment by Levente Polyak (anthraxx) - Wednesday, 20 December 2017, 09:17 GMT
https://git.archlinux.org/svntogit/packages.git/commit/trunk/config?h=packages/linux&id=e42e6ffc6243370215eb33690b3c68f96f181cdb
CONFIG_FAT_DEFAULT_UTF8=y
4.14.4-2

so 4.14.4-1 should be the last kernel without default utf8 charset.
Comment by Musikolo (Musikolo) - Thursday, 21 December 2017, 03:29 GMT
Exactly, by downgrading to linux 4.14.4-1, it works again.

I hope the issue gets sorted out shortly.

Thank you!
Comment by Levente Polyak (anthraxx) - Thursday, 21 December 2017, 08:44 GMT
This is a kernel option that sets the default charset to utf8, this won't be 'sorted out shortly' this is the behavior. you will need to pass options to make it non-utf.

Loading...