Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56653 - [valgrind] glibc dependency broken after gcc multilib merge

Attached to Project: Arch Linux
Opened by Konstantin Gizdov (kgizdov) - Sunday, 10 December 2017, 00:05 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 10 December 2017, 01:05 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
GCC multilib was merged into the core package and now the multilib is provided by lib32-glibc-2.26-8, valgrind dependencies thus cannot be satisfied by pacman

Additional info:
* package version(s) - 3.13.0-4
* config and/or log files etc.


Steps to reproduce:
1. pacman -Syu
2. get error:
resolving dependencies...
warning: ignoring package lib32-glibc-2.26-8
warning: cannot resolve "lib32-glibc=2.26", a dependency of "valgrind"
:: The following package cannot be upgraded due to unresolvable dependencies:
valgrind

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: valgrind: requires lib32-glibc=2.26
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 10 December 2017, 01:05 GMT
Reason for closing:  Not a bug
Additional comments about closing:  warning: ignoring package lib32-glibc-2.26-8

Loading...