Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56634 - [gjs] GNOME shell hangs when dragging window across workspaces after updating gjs

Attached to Project: Arch Linux
Opened by Max Bruckner (FSMaxB) - Friday, 08 December 2017, 15:01 GMT
Last edited by Jan de Groot (JGC) - Friday, 15 December 2017, 23:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
I did a full system update and suddenly GNOME started to hang immediately once I tried to drag a window to another workspace.

By hang I mean that it doesn't react to keystrokes or mouseclicks anymore and is stuck in the window overview screen. Sometimes some of the windows rearrange in the overview, but other than that, nothing happens.

While hanging, the cursor has an arrow shape, similar to the one when resizing windows.

Analysing the list of updated packages, I found out that gjs was the cause. I did a git bisect and the offending commit seems to be:

85f88a18faef28cd5ec09817d048082ec1f6bd97 object: check in gjs_typecheck_object if the object has been finalized

For bisection I used the PKGBUILD of gjs-1.50.2+8+gb65c785-1. In order to get it to build, I needed to comment out the `git revert -n` line in the PKGBUILD for all commits before 85f88a18faef28cd5ec09817d048082ec1f6bd97.

I didn't test newer versions of gjs so far. I also didn't test a different computer.

Additional info:
* good package: 1.50.2
* back package: 1.50.2+8+gb65c785-1
* proprietary nvidia driver (nvidia-dkms)
* Xorg


Steps to reproduce:
Install the bad version of gjs. Log into GNOME and try to drag a window to a different workspace.
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 15 December 2017, 23:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  gjs was reverted to last stable release.
Comment by Max Bruckner (FSMaxB) - Friday, 08 December 2017, 15:22 GMT
I can confirm the bug on another system with Intel GPU and GNOME on Wayland.

I also tested 1.51.2 and the issue doesn't happen with that newer version. I'll try to bisect the fix, although I'm not sure if that makes sense since I think that the commit that broke things is not ancestor of 1.51.2.
Comment by Eli Schwartz (eschwartz) - Friday, 08 December 2017, 15:22 GMT
Comment by Max Bruckner (FSMaxB) - Friday, 08 December 2017, 15:32 GMT
7a9976100152e471729efefa81763ab283ff6320 is broken as well!
Comment by Max Bruckner (FSMaxB) - Friday, 08 December 2017, 15:58 GMT
I did another bisect. This time between 1.51.2 and 7a9976100152e471729efefa81763ab283ff6320

Now it is broken by 40084ad481771f85f0dd183d3e07c9d3ceefa4a6 object: check in gjs_typecheck_object if the object has been finalized

Which seems to be the same commit but cherry-picked.
Comment by Max Bruckner (FSMaxB) - Friday, 08 December 2017, 16:09 GMT
The latest master 05bb8600578890c1a076e1cd3cb815b5ed6e94e1 is also broken.
Comment by Eli Schwartz (eschwartz) - Friday, 08 December 2017, 16:13 GMT
Have you reported an upstream bug yet?
Comment by Robert Clipsham (mrmonday) - Friday, 08 December 2017, 16:15 GMT
I have similar issues since the upgrade - keybindings are broken with the update, and pressing <Super> on its own crashes GNOME. If this is a different issue I'll report a separate one.
Comment by Max Bruckner (FSMaxB) - Friday, 08 December 2017, 16:26 GMT
@eschwartz: Not yet, but I think I will create an account on the upstream gitlab and report it now.
Comment by Max Bruckner (FSMaxB) - Friday, 08 December 2017, 16:37 GMT

Loading...