Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56620 - [gcc] Xwayland segfaults

Attached to Project: Arch Linux
Opened by bbo2adwuff (bbo2adwuff) - Thursday, 07 December 2017, 13:57 GMT
Last edited by Jan de Groot (JGC) - Friday, 08 December 2017, 08:18 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since update the 7.2.1-2 update I cannot
1. use gnome-terminal anymore,
2. login on gdm anymore with my normal user account.

Additional info:

Update:
[2017-12-07 13:00] [ALPM] upgraded gcc-libs (7.2.0-3 -> 7.2.1-2)
[2017-12-07 13:00] [ALPM] upgraded gcc (7.2.0-3 -> 7.2.1-2)
[2017-12-07 13:00] [ALPM] upgraded gcc-fortran (7.2.0-3 -> 7.2.1-2)

ERROR message to 1.:
Dec 07 14:02:45 xps dbus-daemon[627]: [session uid=1001 pid=627] Activating via systemd: service name='org.gnome.Terminal' unit='gnome-terminal-server.service' requested by ':1
Dec 07 14:02:45 xps systemd[612]: Starting GNOME Terminal Server...
Dec 07 14:02:45 xps gnome-terminal-server[2482]: Locale not supported.
Dec 07 14:02:45 xps systemd[612]: gnome-terminal-server.service: Main process exited, code=exited, status=9/n/a
Dec 07 14:02:45 xps systemd[612]: gnome-terminal-server.service: Failed with result 'exit-code'.
Dec 07 14:02:45 xps systemd[612]: Failed to start GNOME Terminal Server.
Dec 07 14:02:49 xps gnome-terminal[2503]: Locale not supported by C library.
Using the fallback 'C' locale.
Dec 07 14:03:10 xps org.gnome.Terminal.desktop[2469]: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gno
Dec 07 14:03:14 xps org.gnome.Terminal.desktop[2503]: Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gno
Dec 07 14:04:45 xps dbus-daemon[627]: [session uid=1001 pid=627] Failed to activate service 'org.gnome.Terminal': timed out (service_start_timeout=120000ms)


ERROR message to 2.:
Dec 07 14:10:50 xps systemd-coredump[735]: Process 697 (Xwayland) of user 1001 dumped core.

Stack trace of thread 697:
#0 0x00007fddaae5a860 raise (libc.so.6)
#1 0x00007fddaae5bec9 abort (libc.so.6)
#2 0x0000562a80d51b9a OsAbort (Xwayland)
#3 0x0000562a80d576b3 n/a (Xwayland)
#4 0x0000562a80d584d5 FatalError (Xwayland)
#5 0x0000562a80be3baf n/a (Xwayland)
#6 0x0000562a80d4f711 n/a (Xwayland)
#7 0x0000562a80d485bb WaitForSomething (Xwayland)
#8 0x0000562a80d143c3 n/a (Xwayland)
#9 0x0000562a80d18660 n/a (Xwayland)
#10 0x00007fddaae46f4a __libc_start_main (libc.so.6)
#11 0x0000562a80be320a _start (Xwayland)

Stack trace of thread 698:
#0 0x00007fddab1eb38d pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007fdda491c9b4 n/a (swrast_dri.so)
#2 0x00007fdda491c808 n/a (swrast_dri.so)
#3 0x00007fddab1e508a start_thread (libpthread.so.0)
#4 0x00007fddaaf1c42f __clone (libc.so.6)

Stack trace of thread 699:
#0 0x00007fddab1eb38d pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007fdda491c9b4 n/a (swrast_dri.so)
#2 0x00007fdda491c808 n/a (swrast_dri.so)
#3 0x00007fddab1e508a start_thread (libpthread.so.0)
#4 0x00007fddaaf1c42f __clone (libc.so.6)

Stack trace of thread 700:
#0 0x00007fddab1eb38d pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007fdda491c9b4 n/a (swrast_dri.so)
#2 0x00007fdda491c808 n/a (swrast_dri.so)
#3 0x00007fddab1e508a start_thread (libpthread.so.0)
#4 0x00007fddaaf1c42f __clone (libc.so.6)

Stack trace of thread 701:
#0 0x00007fddab1eb38d pthread_cond_wait@@GLIBC_2.3.2 (libpthread.so.0)
#1 0x00007fdda491c9b4 n/a (swrast_dri.so)
#2 0x00007fdda491c808 n/a (swrast_dri.so)
#3 0x00007fddab1e508a start_thread (libpthread.so.0)
#4 0x00007fddaaf1c42f __clone (libc.so.6)



Downgrading solved the issue:
[2017-12-07 14:29] [ALPM] downgraded gcc-libs (7.2.1-2 -> 7.2.0-3)
[2017-12-07 14:29] [ALPM] downgraded gcc (7.2.1-2 -> 7.2.0-3)
[2017-12-07 14:29] [ALPM] downgraded gcc-fortran (7.2.1-2 -> 7.2.0-3)


This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 08 December 2017, 08:18 GMT
Reason for closing:  Fixed
Comment by bbo2adwuff (bbo2adwuff) - Thursday, 07 December 2017, 14:06 GMT
My apologies, I forgot to enter a title. Sorry, I cannot edit it anymore.
Comment by Jan de Groot (JGC) - Thursday, 07 December 2017, 20:47 GMT
gnome-terminal doesn't work with non-utf8 locales. your logs indicate something is wrong with locales on your system.
xwayland doesn't crash btw, it aborts because the wayland compositor is gone.
Comment by bbo2adwuff (bbo2adwuff) - Thursday, 07 December 2017, 21:08 GMT
Thanks for your answer. It works after downgrading though!?

Hmmm what's wrong with my locale then?

locale -a
------------
C
en_US.utf8
POSIX


cat /etc/locale.conf
------------
LANG=en_US.UTF-8


Looks fine, right?
Comment by Doug Newgard (Scimmia) - Friday, 08 December 2017, 05:27 GMT
And the output of `locale`? Gnome settings?
Comment by bbo2adwuff (bbo2adwuff) - Friday, 08 December 2017, 06:57 GMT
locale
------------
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

And in Gnome-control-center is language English and Formats United States.
Comment by bbo2adwuff (bbo2adwuff) - Friday, 08 December 2017, 08:10 GMT
Today the issue resolved itself by:

[2017-12-08 08:13] [ALPM] upgraded js52 (52.5.0-1 -> 52.5.2-1)
[2017-12-08 08:13] [ALPM] upgraded gjs (1.50.2-1 -> 1.50.2+8+gb65c785-1)
[2017-12-08 08:13] [ALPM] upgraded guile (2.2.2-1 -> 2.2.3-1)
[2017-12-08 08:13] [ALPM] upgraded libnghttp2 (1.27.0-1 -> 1.28.0-1)
[2017-12-08 08:13] [ALPM] upgraded linux-firmware (20171123.90436ce-1 -> 20171206.fdee922-1)
[2017-12-08 08:13] [ALPM] upgraded linux (4.14.3-1 -> 4.14.4-1)

Don't really know why. But it works now with gcc 7.2.1-2.
(Yesterday I tried it 3 times back and forth, and I always had the problem. But pacman -Syuu today solved it :)

Loading...