Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56618 - [kibana] Wrong node version used

Attached to Project: Community Packages
Opened by Sven Riedel (srd) - Thursday, 07 December 2017, 09:16 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 10 December 2017, 07:18 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The kibana package has a dependency on "nodejs", which includes archlinux' node version (9.2.0 at the time of this writing). However, kibana does not support this version - in fact, trying to start kibana results in the following errors message:

$ systemctl start kibana
$ journalctl status kibana
● kibana.service - Kibana - dashboard for Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/kibana.service; enabled; vendor preset: disabled)
Active: active (running) since Thu 2017-12-07 09:49:58 CET; 2s ago
Main PID: 18089 (node)
Tasks: 10 (limit: 4915)
CGroup: /system.slice/kibana.service
└─18089 /usr/bin/node --max-old-space-size=512 /usr/share/kibana/src/cli --config=/etc/kibana/kibana.yml

Dec 07 09:49:58 plinth systemd[1]: Started Kibana - dashboard for Elasticsearch.
Dec 07 09:49:59 plinth node[18089]: (node:18089) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
Dec 07 09:50:01 plinth node[18089]: {"type":"log","@timestamp":"2017-12-07T08:50:01Z","tags":["fatal"],"pid":18089,"level":"fatal","message":"Unexpected reserved word","error":{"message":"Unexpected reserved word","name":"SyntaxError","stack":"/usr/share/kibana/plugins/x-pack/plugins/reporting/export_types/csv/server/lib/generate_csv.js:51\n for await (const hit of iterator) {\n ^^^^^\n\nSyntaxError: Unexpected reserved word\n at createScript (vm.js:80:10)\n at Object.runInThisContext(vm.js:80:10)\n at Object.runInThisContext (vm.js:152:10)\n at Module._compile (module.js:605:28)\n at loader (/usr/share/kibana/node_modules/babel-register/lib/node.js:144:5)\n at Object.require.extensions.(anonymous function) [as .js] (/usr/share/kibana/node_modules/babel-register/lib/node.js:154:7)\n at Module.load (module.js:560:32)\n at tryModuleLoad (module.js:503:12)\n at Function.Module._load (module.js:495:3)\n at Module.require (module.js:585:17)\n at require (internal/module.js:11:18)\n at Object.<anonymous> (/usr/share/kibana/plugins/x-pack/plugins/reporting/export_types/csv/server/index.js:2:1)\n at Module._compile (module.js:641:30)\n at loader (/usr/share/kibana/node_modules/babel-register/lib/node.js:144:5)"}}


/usr/share/kibana/package.json states that kibana requires a node version of 6.11.5, which is already bundled by upstream in the $KIBANA_ROOT/node.

Please remove the node dependency on kibana, don't remove the bundled node instance and instead use it to avoid such incompatibilities.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 10 December 2017, 07:18 GMT
Reason for closing:  Not a bug
Additional comments about closing:  kibana itself works fine
Comment by Eli Schwartz (eschwartz) - Thursday, 07 December 2017, 15:46 GMT
Or instead we could depend on nodejs-lts-boron...

But FWIW kibana 6.0.1-1 seems to work fine, and /usr/share/kibana/plugins/x-pack/ is not shipped in our package. So it is probably not a kibana issue per se.

Loading...