Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56597 - [evolution] Enchant causing crashes (and associated anomolies)

Attached to Project: Arch Linux
Opened by Mark (javamarket) - Tuesday, 05 December 2017, 16:54 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 05 December 2017, 19:04 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Evolution was crashing during creating an email (new and replies).
After filing a gnome bug report and some additional investigation it has been determined that Enchant is the culprit and likely dictionary related.

Here is the bug on the Gnome tracker:

https://bugzilla.gnome.org/show_bug.cgi?id=791229

Additional info:
* package version(s)

[mtompkins@nuc2 tmp]$ pacaur -Q | grep enchant
enchant 2.1.2-2
enchant1.6 1.6.1-3 (needed for GNUcash)

* config and/or log files etc.


Steps to reproduce:
Create an email in Evolution.
Try to access preferences in Evolution.

Of note, Enchant lists libvoikko as a dependency within the Arch pacakge and I believe it may be this provider causing the problem.

To my understanding, libvoikko is for a Finnish dictionary and shouldn't be something that is made a dependency if that is indeed the case. Other than a default dictionary (arguably English) all others should be within the user space.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 05 December 2017, 19:04 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Broken AUR packages are not our responsibility to fix, but see my comment on the AUR package page.
Comment by Jan de Groot (JGC) - Tuesday, 05 December 2017, 18:22 GMT
Your problem is enchant1.6 placing dictionary modules in the path where enchant 2.x will load them. the modules are probably also linked to libenchant, causing symbol conflicts.

Loading...