Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56589 - [offlineimap] sync got error

Attached to Project: Community Packages
Opened by john_clare (jusss) - Tuesday, 05 December 2017, 13:54 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 11 December 2017, 22:08 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

when I use offlienimap to sync my mails got this error:

[john@moon ~]$ offlineimap
OfflineIMAP 7.1.4
Licensed under the GNU GPL v2 or any later version (with an OpenSSL exception)
imaplib2 v2.57 (bundled), Python v2.7.14, OpenSSL 1.1.0g 2 Nov 2017
*** Processing account qq
Establishing connection to imap.qq.com:993 (qq-remote)
Syncing Deleted Messages: IMAP -> Maildir
Syncing Drafts: IMAP -> Maildir
Syncing INBOX: IMAP -> Maildir
Syncing Junk: IMAP -> Maildir
Copy message UID 260 (1/1) qq-remote:INBOX -> qq-local
Syncing Sent Messages: IMAP -> Maildir
Copy message UID -3 (1/3) qq-local:Sent Messages -> qq-remote
Thread 'Folder Sent Messages [acc: qq]' terminated with exception:
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/offlineimap/threadutil.py", line 160, in run
Thread.run(self)
File "/usr/lib/python2.7/threading.py", line 754, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/lib/python2.7/site-packages/offlineimap/accounts.py", line 643, in syncfolder
localfolder.syncmessagesto(remotefolder, statusfolder)
File "/usr/lib/python2.7/site-packages/offlineimap/folder/Base.py", line 1116, in syncmessagesto
action(dstfolder, statusfolder)
File "/usr/lib/python2.7/site-packages/offlineimap/folder/Base.py", line 944, in __syncmessagesto_copy
self.copymessageto(uid, dstfolder, statusfolder, register=0)
File "/usr/lib/python2.7/site-packages/offlineimap/folder/Base.py", line 844, in copymessageto
new_uid = dstfolder.savemessage(uid, message, flags, rtime)
File "/usr/lib/python2.7/site-packages/offlineimap/folder/IMAP.py", line 669, in savemessage
raise OfflineImapError(msg, OfflineImapError.ERROR.REPO)
OfflineImapError: Saving msg (<20171205093853.GA14393@moon>) in folder 'Sent Messages', repository 'qq-remote' failed (abort). Server responded: NO ['Mail has saved by smtp!']



Last 15 debug messages logged for Folder Sent Messages [acc: qq] prior to exception:
imap: __options2hash returning: {'INTERNALDATE': '"5-Nov-2016 15:27:48 +0800"', 'FLAGS': '(\\Seen)', 'UID': '76'}
imap: __options2hash returning: {'INTERNALDATE': '"7-Nov-2016 23:11:51 +0800"', 'FLAGS': '(\\Seen)', 'UID': '77'}
imap: __options2hash returning: {'INTERNALDATE': '"8-Nov-2016 16:09:27 +0800"', 'FLAGS': '(\\Seen)', 'UID': '78'}
imap: __options2hash returning: {'INTERNALDATE': '"30-Nov-2017 11:54:55 +0800"', 'FLAGS': '(\\Seen)', 'UID': '168'}
imap: __options2hash returning: {'INTERNALDATE': '"30-Nov-2017 14:24:59 +0800"', 'FLAGS': '(\\Seen)', 'UID': '170'}
imap: __options2hash returning: {'INTERNALDATE': '"30-Nov-2017 15:21:08 +0800"', 'FLAGS': '(\\Seen)', 'UID': '171'}
imap: __options2hash returning: {'INTERNALDATE': '"3-Dec-2017 11:37:18 +0800"', 'FLAGS': '(\\Seen)', 'UID': '172'}
imap: __options2hash returning: {'INTERNALDATE': '"3-Dec-2017 11:50:22 +0800"', 'FLAGS': '(\\Seen)', 'UID': '173'}
imap: __options2hash returning: {'INTERNALDATE': '"5-Dec-2017 17:38:55 +0800"', 'FLAGS': '(\\Seen)', 'UID': '174'}
imap: Write mail 'Sent Messages:-3' with flags set(['S'])
: deletemessageheaders: called to delete []
: getmessageheader: called to get message-id
: getmessageheader: eoh = 1970
: getmessageheader: headers = "Date: Tue, 5 Dec 2017 17:38:53 +0800\r\nFrom: l <xx@qq.com>\r\nTo: xxx <xxx@redhat.com>\r\nSubject: Re: xxx?\r\nMessage-ID: <20171205093853.GA14393@moon>\r\nReply-To: x@qq.com\r\nReferences: <5a237488.b02f9d0a.ab517.d400SMTPIN_ADDED_BROKEN@mx.google.com>\r\n <x@redhat.com>\r\nMIME-Version: 1.0\r\nContent-Type: text/plain; charset=utf-8\r\nContent-Disposition: inline\r\nIn-Reply-To: <xxx@redhat.com>\r\nUser-Agent: Mutt/1.9.1 (2017-09-22)\r\n\r\nI xxxr\n xxxr\n"
imap: savemessage: date: "05-Dec-2017 17:38:53 +0800", content: 'Date: Tue, 5 Dec 2017 17:38:53 +0800
From: l <xx@qq.com>
To: x <x@redhat.com>
Subject: Re: how x
>
> xxx
>
'


Additional info:
* package version(s)

Repository : community
Name : offlineimap
Version : 7.1.4-1
Description : Synchronizes emails between two repositories
Architecture : any
URL : http://offlineimap.org/
Licenses : GPL
Groups : None
Provides : None
Depends On : python2-six
Optional Deps : None
Conflicts With : None
Replaces : None
Download Size : 246.48 KiB
Installed Size : 1606.00 KiB
Packager : Jaroslav Lichtblau <svetlemodry@archlinux.org>
Build Date : Sun 05 Nov 2017 06:46:27 PM CST
Validated By : MD5 Sum SHA-256 Sum Signature

* config and/or log files etc.
[general]
ui = basic
accounts = qq
maxsyncaccounts = 1

[Account qq]
localrepository = qq-local
remoterepository = qq-remote

[Repository qq-local]
type = Maildir
localfolders = /var/spool/mail/john

[Repository qq-remote]
type = IMAP
ssl = yes
sslcacertfile = /etc/ssl/certs/ca-certificates.crt
remotehost = imap.qq.com
remoteuser = x
remotepass = x
remoteport = 993



Steps to reproduce:
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 11 December 2017, 22:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  "Server responded: NO ['Mail has saved by smtp!']"
Comment by Doug Newgard (Scimmia) - Saturday, 09 December 2017, 05:38 GMT
Sounds like a server issue

Loading...