Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56575 - [linux] After full update, network will not start (netctl, ethernet-static)

Attached to Project: Arch Linux
Opened by Don Allen (donallen) - Monday, 04 December 2017, 21:25 GMT
Last edited by Jan Steffens (heftig) - Friday, 15 December 2017, 09:33 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
After updating my system yesterday, which included a new kernel, upon reboot, the network failed to start. I use netctl to bring the network up with a static ip address. I am attaching my netctl profile, which has worked for years, a dmesg, and a little script that I am using to bring the network up (this script resides in a directory I made -- /etc/network_breakage -- that also contains a proper copy of resolv.conf, necessary because the failed attempt to bring up the network leaves a useless /etc/resolv.conf).


Additional info:
* package version(s)
* config and/or log files etc.
Here's the output of journalctl -xb
-- Unit netctl@ethernet\x2dstatic.service has begun starting up.
Dec 04 16:07:21 franz network[402]: Starting network profile 'ethernet-static'...
Dec 04 16:07:22 franz kernel: IPv6: ADDRCONF(NETDEV_UP): eno1: link is not ready
Dec 04 16:07:27 franz network[402]: No connection found on interface 'eno1' (timeout)
Dec 04 16:07:27 franz network[402]: Failed to bring the network up for profile 'ethernet-static'
Dec 04 16:07:27 franz kernel: e1000e: eno1 NIC Link is Down
Dec 04 16:07:27 franz systemd[1]: netctl@ethernet\x2dstatic.service: Main process exited, code=exited, status=1/FAILURE
Dec 04 16:07:27 franz systemd[1]: netctl@ethernet\x2dstatic.service: Failed with result 'exit-code'.
Dec 04 16:07:27 franz systemd[1]: Failed to start A basic static ethernet connection.
-- Subject: Unit netctl@ethernet\x2dstatic.service has failed



Steps to reproduce:
Just reboot the system and the network will fail to come up reliably.
This task depends upon

Closed by  Jan Steffens (heftig)
Friday, 15 December 2017, 09:33 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.14.6-1
Comment by Krzysztof Kundzicz (Athantor) - Tuesday, 05 December 2017, 08:41 GMT
This seems to be the upstream bug: https://bugzilla.kernel.org/show_bug.cgi?id=198047

I can confirm it with I217-V + e1000e.
For me, as workaround, works running manually 'dhcpcd -K' (ignoring carrier status).
Comment by loqs (loqs) - Tuesday, 05 December 2017, 10:34 GMT
https://git.kernel.org/pub/scm/linux/kernel/git/stable/stable-queue.git/tree/releases/4.14.3
From the above there were five commits to that module if you are using the git-stable tree
0f478f25d50cb6464678284a13f514fefc16e271
10d0fd29310387313680b12cb69f7b9e11938c8e
830466993daf09adbd179e4c74db07279a088f8c *
2b91745f8a4accb0f04c07433ee4297054bc88b1
8606bf0219f6632a931f7317dad0d4b672b1e035 *

Can you either bisect between 4.14.3 and 4.14.2 or revert each of those commits individually I suggest starting with the two I marked with a * as they look the most likely to me.
Then notify the commit author as well as the upstream bug report.
Comment by Eli Schwartz (eschwartz) - Tuesday, 05 December 2017, 12:13 GMT
Comment 7 on the upstream bugzilla (just posted) indicates that 19110cfbb34d4af0cdfe14cd243f3b09dc95b013 was detected as the problematic commit.
Comment by loqs (loqs) - Tuesday, 05 December 2017, 13:59 GMT Comment by Don Allen (donallen) - Tuesday, 12 December 2017, 04:38 GMT
It's now been a week since I reported this and almost a week since the messages above that say to me that the problem had been identified in the kernel e1000 driver and a fix was known. But after updating every day and receiving one kernel update, my system is still broken (I'm running the 4.14.4 kernel). I don't see this as an Arch issue; it appears that the kernel guys are being a bit slow in getting this fix out. Am I correct?
Comment by Jouke Witteveen (jouke) - Tuesday, 12 December 2017, 09:29 GMT
A potential workaround is to add

TimeoutCarrier=10

to your netctl profile.
Comment by Christian Hesse (eworm) - Tuesday, 12 December 2017, 09:34 GMT
The final patch is here:
https://patchwork.kernel.org/patch/10104349/

But it has neither been committed to Linus' tree nor added to Greg's stable queue or our packages.
Comment by Don Allen (donallen) - Thursday, 14 December 2017, 13:12 GMT
Jouke -- thanks for the suggested workaround. It does work.
Comment by Philipp √úberbacher (hollunder) - Friday, 15 December 2017, 07:46 GMT
Same here, manually enabling static networking using ip works just fine. My card is a RTL8111/8168/8411 however.
Comment by Christian Hesse (eworm) - Friday, 15 December 2017, 09:11 GMT
This should be fixed with linux 4.14.6-1.
Jan, can we close?

Loading...