Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56560 - [linux] TrackStick and physical mouse buttons not working on Lenovo ThinkPad E570p

Attached to Project: Arch Linux
Opened by Jonathan Liu (net147) - Monday, 04 December 2017, 07:38 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 15 April 2018, 00:32 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The red TrackStick and the physical left/middle/right mouse buttons on Lenovo ThinkPad E570p are not working.

Additional info:
* linux 4.14.3

Steps to reproduce:
* Login to KDE
* Try to mouse mouse using red TrackStick or press physical left/middle/right mouse buttons. Observe they don't work.

Patch to fix issue:
* https://patchwork.kernel.org/patch/10081557/mbox/
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 15 April 2018, 00:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.16.1-1 and linux-lts 4.14.33-1
Comment by Eli Schwartz (eschwartz) - Monday, 04 December 2017, 13:09 GMT
Looks like the kernel maintainers aren't quite happy with that patch yet...
Comment by Jonathan Liu (net147) - Monday, 09 April 2018, 12:23 GMT
Should be fixed by 4.16.1 and 4.14.33.

Loading...