Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56558 - initramfs creation fails if older ncurses are installed

Attached to Project: Arch Linux
Opened by balwierz (balwierz) - Sunday, 03 December 2017, 22:19 GMT
Last edited by Eli Schwartz (eschwartz) - Sunday, 03 December 2017, 22:24 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I had an older version of ncurses installed (it was from aur, but the same version existed earlier in [core], so it could have happened without the usage of aur).
The older ncurses package was providing libtinfo.so.5.

"pacman -S linux linux-lts" updated the kernel, but initramfs hook failed to create a functional initramfs.
It rendered my system unbootable (kernel modules for root_fs's device driver not included in /boot/initramfs.img).


[2017-12-03 21:30] [ALPM] running '90-linux-lts.hook'...
[2017-12-03 21:30] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux-lts.preset: 'default'
[2017-12-03 21:30] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux-lts -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-lts.img
[2017-12-03 21:30] [ALPM-SCRIPTLET] hexdump: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory
[2017-12-03 21:30] [ALPM-SCRIPTLET] ==> ERROR: invalid kernel specified: `/boot/vmlinuz-linux-lts'


Proposed solution:
Include specific ncurses version dependency in the package which uses ncurses libraries during initramfs creation.
My guess is that would be util-linux package.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Sunday, 03 December 2017, 22:24 GMT
Reason for closing:  Not a bug
Additional comments about closing:  neither partial updates nor AUR packages are supported

Loading...