Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56551 - [packer-io] Package version 1.1.2-1 lies about included Packer version

Attached to Project: Community Packages
Opened by Jens John (2ion) - Sunday, 03 December 2017, 15:00 GMT
Last edited by Christian Rebischke (Shibumi) - Wednesday, 03 January 2018, 19:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Rebischke (Shibumi)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The current package version is =1.1.2-1, though the included packer binary reports version =1.0.4.

packer --version
1.0.4

Likewise, the packaged version of packer does clearly not include features included in upstream Packer 1.1.2, such as support for separate sriov_support and ena_support attributes for the amazon-ebs builder.

Please fix the package to be equivalent to upstream Packer features, or set an adquate package version.

Additional info:
* package version(s) packer-io=1.1.2-1
This task depends upon

Closed by  Christian Rebischke (Shibumi)
Wednesday, 03 January 2018, 19:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.1.3-2
Comment by Christian Rebischke (Shibumi) - Thursday, 14 December 2017, 15:29 GMT
Hello,
Please note that the binary is called `packer-io` not `packer` due to the package conflict with the AUR-packer.
On my system I get the right version back:

`packer-io --version`
1.1.2

So are you sure with this bug report?!
Comment by Jens John (2ion) - Monday, 01 January 2018, 15:49 GMT
Yes, the issue is still persisting (I'm using a symlink due to company tooling requiring a `packer` binary), but now it shifted to the previous version (1.1.2).

* packer-io=1.1.3-1 (Build date: So 17 Dez 2017 17:45:46 CET)

$ pacman -Qo /usr/bin/packer-io
/usr/bin/packer-io is owned by packer-io 1.1.3-1

$ /usr/bin/packer-io version
Packer v1.1.2

Your version of Packer is out of date! The latest version
is 1.1.3. You can update by downloading from www.packer.io/downloads.html

$ /usr/bin/packer-io --version
1.1.2

For now, I'm now using my own custom packer-io-bin package from the AUR which is just the precompiled upstream binary which reports the correct versions here.

Additional info: pacman -Qi packer-io
Name : packer-io
Version : 1.1.3-1
Description : tool for creating identical machine images for multiple platforms from a single source configuration
Architecture : x86_64
URL : 9698d7283f790aa1d3755ccbd95a1a1cdea9390a
Licenses : MPL
Groups : None
Provides : None
Depends On : glibc
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 61.61 MiB
Packager : Christian Rebischke <Chris.Rebischke@archlinux.org>
Build Date : So 17 Dez 2017 17:45:46 CET
Install Date : Mo 01 Jan 2018 16:43:51 CET
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature

Comment by Christian Rebischke (Shibumi) - Wednesday, 03 January 2018, 19:18 GMT
Oh.. I see the problem.
I mixed up the "url" line with the "packer_commit_id" line in my pkgbuild. That's why the last update was wrong. Thanks for the hint!

Loading...