Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56529 - [glibc] Glibc 2.26 breaks bash and other shells in container.

Attached to Project: Arch Linux
Opened by Anton Mikhalev (amhv) - Friday, 01 December 2017, 13:02 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Wednesday, 27 December 2017, 08:50 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Running an arch, which has glibc 2.26 installed, within an nspawn container seems to
completely break the ability to use Ctrl-C in bash. Bash will not respond to Ctrl-C presses
at all and it will throw the following of error during startup:

-bash: cannot set terminal process group (-1): Inappropriate ioctl for device
-bash: no job control in this shell

Downgrading back to glibc 2.25 within the container fixes the problem. Other shells are
affected too, I've tested zsh and sh which were behaving in the same way as
bash (not responding to Ctrl-C). Fish refused to start at all.

Additional info:
* package version(s): glibc 2.26

Steps to reproduce:
1. Get latest arch bootstrap image.
2. Launch systemd-nspawn container from the image.
3. Observe not working Ctrl-C and bash errors.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Wednesday, 27 December 2017, 08:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  glibc 2.26-9
Comment by Doug Newgard (Scimmia) - Friday, 01 December 2017, 15:18 GMT
"package version" under additional info doesn't give the package version. Versions in Arch include the -<pkgrel> at the end.

Anyway, upstream ticket: https://sourceware.org/bugzilla/show_bug.cgi?id=22145
Comment by Anton Mikhalev (amhv) - Friday, 01 December 2017, 15:43 GMT
Apologies, it is glibc 2.26-6.
Comment by Anton Mikhalev (amhv) - Friday, 01 December 2017, 17:52 GMT
Thanks for pointing out the upstream bug, I built a custom glibc with patches
from their bugtracker and the problem was fixed! I had to make minor modifications
to the patches because they wouldn't apply cleanly against arch's glibc.

I've attached the modified patchset, in case anyone's interested.
Comment by Bartłomiej Piotrowski (Barthalion) - Sunday, 10 December 2017, 21:40 GMT
Thanks Anton, I will look at your backported patches and most likely apply them during the week.

Loading...