Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56518 - [nginx-mainline] Version 1.13.7-2 dependency on [testing] (mailcap) in [community]

Attached to Project: Community Packages
Opened by Sal Wolffs (swolffs) - Thursday, 30 November 2017, 13:23 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 30 November 2017, 15:00 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Giancarlo Razzolini (grazzolini)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

On running pacman -Syu with nginx-mainline installed, I get a complaint about not being able to resolve a dependency on mailcap. Some searching reveals that this is because mailcap is in the testing repository. Given the "here be dragons" warnings surrounding [testing], it doesn't seem like enabling that repository should be necessary to be able to use packages in [community].

Digging through the history of the nginx-mainline package, two commits stand out: one adding the dependency on mailcap, the other moving the affected version of the package from [community-testing] to [community], the second being the most recent commit, at less than an hour old.

commit adding mailcap dependency: https://git.archlinux.org/svntogit/community.git/commit/?h=packages/nginx-mainline&id=a5771a731499d227c5eb75f8caa4f98c6c064aa4
commit db-moving from community-testing to community: https://git.archlinux.org/svntogit/community.git/commit/?h=packages/nginx-mainline&id=158a3e50f036779e657f3ca537b7de8404332e83

Package version: 1.13.7-2
Log, prompts edited for GMT and stripped username@hostname. current date 2017-11-30:
[13:15 ~]$ sudo pacman -Syu
:: Synchronising package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
:: Replace gtk3-print-backends with extra/gtk3? [Y/n]
resolving dependencies...
warning: cannot resolve "mailcap", a dependency of "nginx-mainline"
:: The following package cannot be upgraded due to unresolvable dependencies:
nginx-mainline

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: nginx-mainline: requires mailcap
[13:15 ~]$



Steps to reproduce:
1. Do not have the testing repository enabled, nor mailcap dependency satisfied through some other means.
2. Have nginx-mainline installed.
3. Run pacman -Syu
Alternatively, untried:
2. Don't have nginx-mainline installed
3. run pacman -Syu
4. run pacman -S nginx-mainline
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 30 November 2017, 15:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  mailcap is now available in [extra]
Comment by Giancarlo Razzolini (grazzolini) - Thursday, 30 November 2017, 13:36 GMT
This was just lack of coordination on my part with Jan. We are moving mailcap from [testing] as well. Should be solved in the next few hours.
Comment by Giancarlo Razzolini (grazzolini) - Thursday, 30 November 2017, 13:45 GMT
mailcap was just moved to [extra]. As soon as the mirrors update, you should be able to upgrade nginx-mainline. Note that nginx will also depend on mailcap as well. Please update this to let me know if it is working for you.
Comment by Sal Wolffs (swolffs) - Thursday, 30 November 2017, 13:55 GMT
Thank you. Will wait for mirrors to update, then report back.
Comment by Sal Wolffs (swolffs) - Thursday, 30 November 2017, 14:53 GMT
Works now, thanks.

Loading...