Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56509 - [virtualbox-guest-modules-arch] [virtualbox] VeraCrypt can not open containers on shared folders

Attached to Project: Community Packages
Opened by Daniel Schmidt (daniel.schmidt) - Wednesday, 29 November 2017, 14:02 GMT
Last edited by Christian Rebischke (Shibumi) - Saturday, 09 February 2019, 14:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Christian Hesse (eworm)
Christian Rebischke (Shibumi)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After updating virtualbox-guest-modules-arch package to version 5.2.2-1, VeraCrypt (current version: 1.21) is not able to open encrypted file containers on shared folders any more. It tells me
"I/O error:
/dev/mapper/veracrypt1
The drive is damaged (there is a physical defect on it) or cable is damaged, or the memory is malfunctioning."
I can open the same container with the same VeraCrypt version on the Windows 10 host without any problem.

Environment:
My arch installation is inside a virtual box vm. Therefore I have the current guest modules packages installed.
My arch vm has shared folders to the host OS (Windows 10). On one of these shared folders there is an encrypted file container that should be decrypted / mounted with VeraCrypt.
* Guest OS: arch installation: Updated everything to current package version in repos (2017-11-29)
* Host OS: Windows 10 with virtual box Version 5.2.2 r119230 - latest official version

Workaround:
I found out that if I downgrade the virtualbox-guest-modules-arch to version 5.2.0-5 (I used the package from my pacman cache: virtualbox-guest-modules-arch-5.2.0-5-x86_64.pkg.tar.xz), the problem went away. As soon as I update to later packages (virtualbox-guest-modules-arch-5.2.2-1-x86_64.pkg.tar.xz or the latest package virtualbox-guest-modules-arch-5.2.2-4-x86_64.pkg.tar.xz) the problem occurs again.

Steps to reproduce:
* Boot the arch linux inside the virtual box VM
* open VeraCrypt
* Try to mount a VeraCrypt container that is located on a shared folder between the arch guest and the Windows 10 host
--> Error message occurs (see screenshot).

If you need further information, please don't hesitate to contact me.
This task depends upon

Closed by  Christian Rebischke (Shibumi)
Saturday, 09 February 2019, 14:58 GMT
Reason for closing:  No response
Additional comments about closing:  no response since august.
Comment by Levente Polyak (anthraxx) - Wednesday, 29 November 2017, 15:08 GMT
well this is not a VeraCrypt problem but you kernel in the VM is bound to a specific version. its either that you have not rebooted after a linux kernel update or the virtualbox-guest-modules-arch in the non testing repo is not build against the latest kernel in non testing repo
Comment by Doug Newgard (Scimmia) - Wednesday, 29 November 2017, 16:15 GMT
5.2.0-5, 5.2.2-1, and 5.2.2-4 were all built against the latest kernel in Core and should work; anthraxx was assuming something different.

He's right that it's not a veracrypt problem, though. Did you load the new modules after updating the package? If so, it would appear to be a vbox problem.

Edit: Assuming the modules actually loaded without an error, of course.
Comment by Daniel Schmidt (daniel.schmidt) - Thursday, 30 November 2017, 08:04 GMT
How can I check if the module is loaded?
Comment by Doug Newgard (Scimmia) - Friday, 01 December 2017, 18:48 GMT
30 seconds with google should turn that info up easily
Comment by Daniel Schmidt (daniel.schmidt) - Monday, 04 December 2017, 06:36 GMT
Thank you Dough, I can type lsmod. My question was, if you need further information or log files too see possible subcomponents states...

lsmod with virtualbox-guest-modules-arch-5.2.2-4-x86_64.pkg.tar.xz / virtualbox-guest-modules-arch-5.2.2-6-x86_64.pkg.tar.xz installed:
lsmod | grep vboxguest
vboxguest 229376 5 vboxsf
Comment by Daniel Schmidt (daniel.schmidt) - Monday, 04 December 2017, 06:38 GMT
virtualbox-guest-modules-arch version 5.2.2-6 has the same problem (virtualbox-guest-modules-arch-5.2.2-6-x86_64.pkg.tar.xz). Of course I did a consistent upgrade of all repositories today including the new kernel 4.14.
Comment by Christian Hesse (eworm) - Tuesday, 05 December 2017, 21:26 GMT
Sounds like Oracle decided to clean up and removed code that they thought is unused, legacy stuff or whatever.
I guess opening an upstream bug report is the way to go.

I do not think there is anything we can do here.
Comment by Christian Hesse (eworm) - Tuesday, 05 December 2017, 21:27 GMT
Possibly related to changeset 69149?
https://www.virtualbox.org/changeset/69149/vbox

I did not take a detailed look though.
Comment by Christian Rebischke (Shibumi) - Sunday, 19 August 2018, 02:18 GMT
@Daniel.Schmidt
Is this still an issue? Any update?

Loading...