Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56490 - [firefox] Build doesn't include WebRender

Attached to Project: Arch Linux
Opened by Konstantin Gizdov (kgizdov) - Tuesday, 28 November 2017, 01:14 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 28 November 2017, 09:05 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Current build of Firefox does not ship with WebRender. Impossible to enable hardware acceleration due to this. Results in bad performance on laptops with iGPUs & HiDPI screens.

Additional info:
* package version(s) - 57.0-2
* config and/or log files etc. - N/A


Steps to reproduce:
1. Open Firefox
2. Type 'about:support' in address bar & press enter
3. Under 'Graphics' section:
-- WEBRENDER: opt-in by default: WebRender is an opt-in feature
unavailable by runtime: Build doesn't include WebRender
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 28 November 2017, 09:05 GMT
Reason for closing:  Not a bug
Comment by Jan Alexander Steffens (heftig) - Tuesday, 28 November 2017, 09:05 GMT
WebRender is experimental and only available in Firefox Nightly.

Hardware accel is available if you activate "layers.acceleration.force-enabled".

Loading...