Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56461 - [jupyter] missing "jupyter" binary may break dependent software

Attached to Project: Community Packages
Opened by Christian Schulze (heimdall) - Sunday, 26 November 2017, 14:15 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 26 November 2017, 14:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since the package was split into sub commands in 4.1.0-6 one cannot install the R kernel as the "jupyter" binary is missing and was split into several "sub command wise binaries". The installspec function fails with the following error:

Error in IRkernel::installspec() :
jupyter-client has to be installed but “jupyter kernelspec --version” exited with code 127.

I hacked together the following /usr/bin/jupyter to install the R kernel:

https://gist.github.com/ChristianSch/ab2c2e41f7bc04feb29d57b4650ba4a3

I feel that this functionality might not only break the IRkernel but a lot of other things. Is there anything I missed or is this a broken functionality?

Steps to reproduce:
Install jupyter and R. In an R session (with devtools installed) run:

devtools::install_github('IRkernel/IRkernel')
IRkernel::installspec()
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 26 November 2017, 14:29 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Sunday, 26 November 2017, 14:25 GMT
/usr/bin/jupyter is in the python-jupyter_core package, which is a dependency of jupyter. If you don't have it there's something wrong with your installation.
Comment by Christian Schulze (heimdall) - Sunday, 26 November 2017, 14:28 GMT
I reinstalled the package and can confirm that this is the case. I have no idea what might have caused this. Thanks for the quick response.

Loading...