Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56414 - [linux] possible oops in use of elevator parameter

Attached to Project: Arch Linux
Opened by loqs (loqs) - Wednesday, 22 November 2017, 21:51 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 04 February 2018, 20:45 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since 4.12 introduced MQ elevators specifying one as a value to the elevator parameter will cause an OOPS on if the device is SQ.
Issue is patched in mainline for 4.15 not queued for stable.

Additional info:
* 4.14.1-2
* https://bugzilla.kernel.org/show_bug.cgi?id=196695#c10
* https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit?id=2527d99789e248576ac8081530cd4fd88730f8c7

Steps to reproduce:
boot with kernel parameter elevator=bfq on a system with a root device that is SQ.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 04 February 2018, 20:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.15-1
Comment by loqs (loqs) - Wednesday, 22 November 2017, 23:06 GMT
Forgot to add any such device affected by the OOPS will not become available and if the device is the root device the system will be prevented from booting.

Loading...