Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56413 - [linux] Fails to initialize kfd

Attached to Project: Arch Linux
Opened by Velius Guio (c0re_lukc) - Wednesday, 22 November 2017, 20:55 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 26 February 2018, 16:31 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

After upgrading to kernel linux-4.14.1-1-x86_64, I get the new errors during boot:
kfd: DID 9553 is missing in supported_devices
kfd: kgd2kfd_probe failed

After this upgrade, I updated to linux-4.14.1-2-x86_64, and this error has remained in this version.
I think this error message is caused by the introduction of this patch:
https://patchwork.freedesktop.org/patch/171967/

Additional info:
Boot log (journalctl -b) on linux-4.14.1-2-x86_64.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 26 February 2018, 16:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.15
Comment by Velius Guio (c0re_lukc) - Wednesday, 22 November 2017, 20:59 GMT
oh, my log
   boot.log (111.6 KiB)
Comment by loqs (loqs) - Wednesday, 22 November 2017, 21:40 GMT
Would suggest bisecting between 4.13 and 4.14 to determine which commit is the cause then report it upstream if it has not been already.
Comment by Maxim (mxfm) - Thursday, 07 December 2017, 17:51 GMT
I also started receiving recently:
kfd kfd: DID 6840 is missing in supported_devices
kfd kfd: kgd2kfd_probe failed

Unfortunately, I cannot say exact day, but it is likely related to kernel update to 4.14.1-1
Comment by Mike Simms (micsim35) - Friday, 08 December 2017, 12:32 GMT
I too have had this 'more helpful' message since installing kernel 4.14.0 onwards. with 4.13 and 4.9 there was no error message.

I concur with I think this error message is caused by the introduction of this patch:
https://patchwork.freedesktop.org/patch/171967/

16/11/2017 17:50 kfd kfd DID 9830 is missing in supported_devices
16/11/2017 17:50 kfd kfd kgd2kfd_probe failed

Hardware concerned is Radeon R3 (8400) built into AMD Athlon 5350 APU. It works perfectly well so I'm just ignoring the message. can the probing be prevented via blacklisting kfd or kgd2kfd without causing major stability problems? I already blacklist sp5100_tco for similar annoying message reasons.
Comment by loqs (loqs) - Friday, 08 December 2017, 13:25 GMT
As the probe is failing would not expect the amdkfd module to be providing any functionality to that system
so blacklisting it should not be harmful unless some other module depends on it but does not actually use it.
Comment by Pablo H.Cerdan (phcerdan) - Thursday, 21 December 2017, 14:10 GMT
I am getting the same problem, but for me the kfd module seems needed. gdm doesn't launch.

kfd kfd: DID 689c is missing in supported_devices
kfd kfd: kgd2kfd_probe failed

I am reading this article: https://www.phoronix.com/scan.php?page=news_item&px=AMDKFD-More-For-Linux-4.15
It seems the card is getting dropped there, but... I am using xf86-video-ati driver (the old open source driver), not the new amdgpu. What is the relationship between amdkfd and ati drivers?
Quite ignorant about this.
Comment by Benjamin Fani Sani (errelion) - Tuesday, 02 January 2018, 17:06 GMT
How do you identify the name of the module you have to blacklist? I tried blacklisting kfd and kgd2kfd, but the error still shows up. I also couldnt find anythig related to it using "mkinitcpio -M", so i
guess the name of the module has to be something else.
Comment by Mike Simms (micsim35) - Tuesday, 02 January 2018, 17:18 GMT
The module to blacklist is amdkfd, it's only needed for DRM but since it doesn't actually work blacklisting it shouldn't break gdm
Comment by kts (kts) - Saturday, 10 February 2018, 11:35 GMT
It's gone now with the new kernel 4.15.
Comment by Mike Simms (micsim35) - Saturday, 10 February 2018, 12:52 GMT
@ kts thanks for the notification. I've removed it from the blacklist and it's indeed working properly again now with my hardware too.

AMD Athlon 5350 with R3 GPU

Loading...