Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56399 - [elasticsearch] 6.0.0-1 Unable to create log file

Attached to Project: Community Packages
Opened by Reed Law (reedlaw) - Tuesday, 21 November 2017, 16:50 GMT
Last edited by Massimiliano Torromeo (mtorromeo) - Thursday, 23 November 2017, 16:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Massimiliano Torromeo (mtorromeo)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After running "systemctl start elasticsearch", elasticsearch fails to start. "journalctl -xe" reveals this error:

2017-11-21 08:28:38,101 main ERROR Unable to create file /usr/share/elasticsearch/logs/elasticsearch.log java.io.IOException: Could not create directory /usr/share/elasticsearch/logs

Additional info:
The issue is resolved by changing "/etc/elasticsearch/elasticsearch.yml" to specify log and data paths as follows:

# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: /var/lib/elasticsearch
#
# Path to log files:
#
path.logs: /var/log/elasticsearch

The directory, /usr/share/elasticsearch/logs, is not created by the package installer, but /var/log/elasticsearch is.

Steps to reproduce:
1. Install "elasticsearch"
2. Run "systemctl start elasticsearch"
3. Elasticsearch fails to start
This task depends upon

Closed by  Massimiliano Torromeo (mtorromeo)
Thursday, 23 November 2017, 16:52 GMT
Reason for closing:  Duplicate
Comment by Christian (close2) - Thursday, 23 November 2017, 10:56 GMT
Duplicate of #56393
Comment by Doug Newgard (Scimmia) - Thursday, 23 November 2017, 15:20 GMT
I don't think so. Errors are different.
Comment by Massimiliano Torromeo (mtorromeo) - Thursday, 23 November 2017, 16:52 GMT
It is a duplicate. The error log was not reported in #56393 but it's the same issue

Loading...