Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56397 - [conky] Package does not build due to missing GCC7 patch.

Attached to Project: Arch Linux
Opened by Doron Behar (doronbehar) - Tuesday, 21 November 2017, 12:47 GMT
Last edited by Gaetan Bisson (vesath) - Tuesday, 21 November 2017, 19:29 GMT
Task Type Support Request
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a question about conky.

The version currently on the official repositories and on my machine as well is `1.10.6_pre` (from`conky --version`). I'm wondering: is this the newest version released ever? On conky's releases page ong Github the latest release is called `1.10.6` - without `pre`.
What is the difference between the two? When I tried to make my edit the original `PKGBUILD` and build the package on my own machine, so that I could be sure I can flag the package as outated, I encountered this error:
https://github.com/brndnmtthws/conky/issues/422
This task depends upon

Closed by  Gaetan Bisson (vesath)
Tuesday, 21 November 2017, 19:29 GMT
Reason for closing:  Fixed
Comment by Jelle van der Waa (jelly) - Tuesday, 21 November 2017, 12:59 GMT
This is not a bug and all the information is actually provided upstream and in our PKGBUILD.

1) The pre comes from upstream, see the CMAKE file

https://github.com/brndnmtthws/conky/blob/d7ee00adf0ace2880b2fee178716d1db7a318c59/cmake/Conky.cmake#L114

2) Building requires a gcc7 patch, so the bug report you made is probably about GCC 7 compilation. But the patch is missing in the svn repo. See https://github.com/brndnmtthws/conky/pull/402

And don't flag packages out of date because of build issues, it's only for new updates.
Comment by Gaetan Bisson (vesath) - Tuesday, 21 November 2017, 19:14 GMT
The patch was introduced to fix  FS#54223  but I only commited the new PKGBUILD to SVN and never rebuilt the package, so devtools never noticed the missing patch. It's all good now. Cheers.

Loading...