FS#56372 - [usb_modeswitch] the file /usr/lib/systemd/system/usb_modeswitch@.service is delete

Attached to Project: Community Packages
Opened by Idontknow (Archtux) - Saturday, 18 November 2017, 21:04 GMT
Last edited by Eli Schwartz (eschwartz) - Friday, 05 January 2018, 16:20 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No



The file /usr/lib/systemd/system/usb_modeswitch@.service is remove in package usb_modeswitch ( https://www.archlinux.org/packages/community/x86_64/usb_modeswitch/ ). But this file is in the package compile by "pacman -Sb usb_modeswitch". Problem dongle 4g don't switch in modem mode but stay in storage mass mode on start.

Additional info:
Version : 2.5.1-1

This task depends upon

Closed by  Eli Schwartz (eschwartz)
Friday, 05 January 2018, 16:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  usb_modeswitch 2.5.2-1
Comment by Doug Newgard (Scimmia) - Saturday, 18 November 2017, 21:48 GMT
There is no pacman -Sb. I'm going to assume you're using yaourt, and also not building in a clean chroot. This appears to have been built in an older chroot that doesn't include systemd, so I'm guessing the build system does some autodetection here?
Comment by Idontknow (Archtux) - Sunday, 19 November 2017, 09:15 GMT
I'm sorry for this mistake. It's "yaourt -Sb usb_modeswitch" no "pacman -Sb usb_modeswitch". Thank you. I understand better the problem.
Comment by Sergey Kvachonok (ravenexp) - Sunday, 17 December 2017, 15:06 GMT
Without /usr/lib/systemd/system/usb_modeswitch@.service systemd unit usb_modeswitch cannot function at all in a systemd-enabled environment.

I wonder why this issue is tagged as a low priority feature request. The package is completely broken as shipped.
I had to download the source tarball and extract the missing unit file from there to make it work.
Comment by Chester Wisniewski (chetwisniewski) - Friday, 29 December 2017, 02:10 GMT
Not sure why this is marked feature request? It isn't a feature, it is simply completely broken. Can someone change the status?
Comment by Sergey Kvachonok (ravenexp) - Friday, 29 December 2017, 10:12 GMT
Maybe reverting the package to the previous version would temporarily fix the situation.

This problem is not very easy to discover, as there are no clear error messages,
and every Arch user running systemd is going to experience this problem with usb_modeswitch at some point,
and then probably complain to the upstream about something that is an Arch-only packaging issue.
Comment by Francisco Cribari (cribari) - Saturday, 30 December 2017, 21:39 GMT
I run Arch and Manjaro on two different notebooks. Under Arch I solved the problem by downgrading usb_modeswitch to version 2.5.0-1. The problem was discussed in the Manjaro Forum and the Manjaro devs fixed it, so that version 2.5.1 works under Manjaro; see https://forum.manjaro.org/t/usb-modeswitch-2-5-1-1/35112/8
Comment by BobLite (MiXXer) - Thursday, 04 January 2018, 09:46 GMT
A new version of the package - 2.5.2
I hope this time will be collected without errors.
Comment by Sergej Pupykin (sergej) - Friday, 05 January 2018, 16:01 GMT
It looks like it is fixed in 2.5.2

checkpkg says:
> usr/lib/systemd/system/usb_modeswitch@.service