Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56265 - [liri-terminal] Not working because dependencies are not correct

Attached to Project: Community Packages
Opened by Czémán Barnabás (barni2000) - Tuesday, 07 November 2017, 11:55 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 08 November 2017, 14:30 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Felix Yan (felixonmars)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:
liri-terminal not working because dependencies are not correct

Additional info:
* liri-terminal 0.0.0.20170213-1

Steps to reproduce:
1. $ liri-terminal
QQmlApplicationEngine failed to load component
qrc:/qml/main.qml:206 Type ConfirmCloseDialog unavailable
qrc:/qml/ConfirmCloseDialog.qml:25 Type FluidControls.AlertDialog unavailable
file:///usr/lib/qt/qml/Fluid/Controls/AlertDialog.qml:32 Type Dialog unavailable
file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/Dialog.qml:80 Cannot assign to non-existent property "buttonBox"
This task depends upon

Comment by Doug Newgard (Scimmia) - Wednesday, 08 November 2017, 14:29 GMT
And how are the deps not correct?
Comment by Felix Yan (felixonmars) - Wednesday, 08 November 2017, 19:37 GMT
Which fluid package are you using? liri-terminal starts fine here even without the existence of /usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/
Comment by Antonio Rojas (arojas) - Wednesday, 08 November 2017, 20:49 GMT
I suppose the OP is using Plasma, which sets the org.kde.desktop QQC2 theme. Not sure if the issue is in fluid or in qqc2-desktop-style.
Comment by Ivy Foster (escondida) - Friday, 11 October 2019, 00:16 GMT
barni2000, do you still experience this problem?

Loading...