Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56238 - [vulkan-icd-loader] package-config

Attached to Project: Arch Linux
Opened by Philip Sequeira (qmega) - Saturday, 04 November 2017, 18:19 GMT
Last edited by Laurent Carlier (lordheavy) - Friday, 18 May 2018, 14:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Friday, 18 May 2018, 14:59 GMT
Reason for closing:  Won't implement
Comment by Philip Sequeira (qmega) - Saturday, 04 November 2017, 18:23 GMT
Sorry, submitted by accident, can't figure out how to edit.

vulkan-icd-loader includes vulkan.pc, which references the vulkan headers, but those are in the vulkan-headers package. If you have the former installed, but not the latter, a program using pkg-config to detect vulkan as an optional feature will find it, but then fail to compile because of the missing header.

Is there really any point in these two packages being separate in the first place? They're both tiny, and Arch packages generally include headers along with the libraries rather than in a separate package.
Comment by Bruno Pagani (ArchangeGabriel) - Sunday, 13 May 2018, 10:07 GMT
I’ve seen this issue too, and I concur that we normally don’t split headers.
Comment by Laurent Carlier (lordheavy) - Sunday, 13 May 2018, 10:55 GMT
Headers aren't splitted, they are built with vulkan-docs package.

You can't build headers as part of the icd loader, as it's not updated at every spec update, otherwise you'll have a vulkan-html-docs out-of-sync with vulkan-headers package.
vulkan.pc file doesn't refere to any headers file, just paths for libs and headers to help configure scripts.

We could add vulkan-headers as an optional dependency, but i don't like that because it adds only more noise.

Loading...