Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56236 - [polymake] does not run

Attached to Project: Community Packages
Opened by Long Huynh Huu (long) - Saturday, 04 November 2017, 16:45 GMT
Last edited by Antonio Rojas (arojas) - Monday, 04 December 2017, 10:06 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Polymake does not run

$ polymake
Can't locate loadable object for module Polymake::Ext in @INC (@INC contains: /usr/share/polymake/perllib /usr/lib/polymake/perlx /home/long/perl5/lib/perl5 /usr/lib/perl5/5.26/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.26/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.26/core_perl /usr/share/perl5/core_perl) at /usr/share/polymake/perllib/Polymake/Namespaces.pm line 17.
Compilation failed in require at /usr/share/polymake/perllib/Polymake/Namespaces.pm line 17.
BEGIN failed--compilation aborted at /usr/share/polymake/perllib/Polymake/Namespaces.pm line 17.
Compilation failed in require at /usr/share/polymake/perllib/Polymake.pm line 27.
BEGIN failed--compilation aborted at /usr/share/polymake/perllib/Polymake.pm line 27.
Compilation failed in require at /usr/bin/polymake line 162.
BEGIN failed--compilation aborted at /usr/bin/polymake line 162.

$ pacman -Qi polymake
Name : polymake
Version : 3.1-4
Beschreibung : Open source software for research in polyhedral geometry
Architektur : x86_64
[...]

$ pacman -Qi perl
Name : perl
Version : 5.26.1-1
Beschreibung : A highly capable, feature-rich programming language
Architektur : x86_64
[...]

This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 04 December 2017, 10:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  polymake 3.1-5
Comment by Laith (LaisRast) - Sunday, 19 November 2017, 21:49 GMT
I do have the same problem.
Is there any fix?
Comment by Antonio Rojas (arojas) - Sunday, 19 November 2017, 21:54 GMT
The fix for this issue it a simple rebuild, but unfortunately rebuilding the package currently causes undefined symbol errors that I still don't know how to solve. Help is welcome.

Loading...