Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56234 - [mono-addins] Key is disabled - Rebuild package with the signature of Levente Polyak

Attached to Project: Arch Linux
Opened by Charles (user001101) - Saturday, 04 November 2017, 10:33 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Saturday, 30 December 2017, 13:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:

The key by Daniel Isenmann has been disabled. Please rebuild the package with the signature of the current maintainer, Levente Polyak.

Additional info:
* package version(s)
1.1.1

* config and/or log files etc.


Steps to reproduce:

└─[$] <> sudo pacman -S mono-addins
resolving dependencies...
looking for conflicting packages...

Packages (1) mono-addins-1.1-1

Total Download Size: 0.36 MiB
Total Installed Size: 1.15 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
mono-addins-1.1-1-x86_64 366.5 KiB 1666K/s 00:00 [################################] 100%
(1/1) checking keys in keyring [################################] 100%
(1/1) checking package integrity [################################] 100%
error: mono-addins: key "Daniel Isenmann <daniel@archlinux.org>" is disabled
:: File /var/cache/pacman/pkg/mono-addins-1.1-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Saturday, 30 December 2017, 13:51 GMT
Reason for closing:  Fixed
Comment by Ryan Whited (godofgrunts) - Friday, 10 November 2017, 13:00 GMT
Issue is still persisting. Can't install pinta because it requires mono-addins
Comment by Levente Polyak (anthraxx) - Friday, 10 November 2017, 13:04 GMT
its been worked on, it can't be rebuilt because its shit and doesn't work with newer mono plus their releases are shit.
TL;DR: you have not been forgotten
Comment by Ryan Whited (godofgrunts) - Friday, 10 November 2017, 13:09 GMT
Thanks for the quick response Levente
Comment by Federico Pasqua (eisterman) - Monday, 20 November 2017, 10:56 GMT
Issue is still persisting, what is the problem with mono?
Comment by A. Bosch (progandy) - Monday, 27 November 2017, 18:58 GMT
Would it be possible to simply sign the old package with a new key without rebuilding?
Comment by Ryan Whited (godofgrunts) - Monday, 27 November 2017, 19:40 GMT
Just so you guys know, in AUR mono-addins-git builds successfully. You may want to look into whatever they are doing to help you with your problem.

https://aur.archlinux.org/packages/mono-addins-git/
Comment by Alex Agostino (anvilofcrom) - Thursday, 14 December 2017, 03:11 GMT
Is this package going to be removed?
Comment by Preston (timidger) - Sunday, 17 December 2017, 03:54 GMT
Issue still persisting, any update on this?
Comment by Bartłomiej Piotrowski (Barthalion) - Monday, 18 December 2017, 21:01 GMT
2 months is way too long to fix something completely breaking installation…

So I fixed it myself, borrowing the idea from AUR's git counterpart. Please try testing/mono-addins, as I don't use anything that uses Mono.
Comment by Bartłomiej Piotrowski (Barthalion) - Saturday, 30 December 2017, 13:50 GMT
I assume no issues. Moving to [extra].

Loading...