Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56215 - [texlive-core] errors with Babel French

Attached to Project: Arch Linux
Opened by A. Parzy (hermogene) - Friday, 03 November 2017, 10:16 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Monday, 06 November 2017, 20:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Can't use any of the french babel packages (french, frenchb etc.) with this version of texlive. Works fine with former version (44515)

Additional info:
* package version(s)
* config and/or log files etc.

/usr/share/texmf-dist/tex/generic/e-french/french.sty:3201: Undefined control sequence.
\bbl@switch ...xtras}{}\ifcase \bbl@opt@hyphenmap
\or \def \BabelLower ##1##...l.3201 \GOfrench
\let\GOfrench\relax%
/usr/share/texmf-dist/tex/generic/e-french/french.sty:3201: Missing number, treated as zero.
<to be read again>
\relax
l.3201 \GOfrench
\let\GOfrench\relax%
))))
No file foo.aux.
(/usr/share/texmf-dist/tex/latex/lm/t1lmr.fd)
./foo.tex:6: Undefined control sequence.
\bbl@switch ...xtras}{}\ifcase \bbl@opt@hyphenmap
\or \def \BabelLower ##1##...l.6 \begin{document}

./foo.tex:6: Missing number, treated as zero.
<to be read again>
\relax
l.6 \begin{document}

[1{/home/ap/.texlive/texmf-var/fonts/map/pdftex/updmap/pdftex.map}] (./foo.aux
./foo.aux:5: Undefined control sequence.
\bbl@switch ...xtras}{}\ifcase \bbl@opt@hyphenmap
\or \def \BabelLower ##1##...l.5 \select@language{french}

./foo.aux:5: Missing number, treated as zero.
<to be read again>
\relax
l.5 \select@language{french}

./foo.aux:9: Undefined control sequence.
\bbl@switch ...xtras}{}\ifcase \bbl@opt@hyphenmap
\or \def \BabelLower ##1##...l.9 \select@language{french}

./foo.aux:9: Missing number, treated as zero.
<to be read again>
\relax
l.9 \select@language{french}

) )


Steps to reproduce:

compile with joined file foo.tex
   foo.tex (0.1 KiB)
   foo.log (10.2 KiB)
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Monday, 06 November 2017, 20:02 GMT
Reason for closing:  Works for me
Additional comments about closing:  Compilation works without issue with a vanilla install.
Comment by Rémy Oudompheng (remyoudompheng) - Monday, 06 November 2017, 20:01 GMT
Hello,
Your logfile foo.log shows that compilation is using a local file that you have
(/home/ap/texmf/tex/latex/frenchle/french.ldf), dating back to 2006.

Local files have precedence over system files. I strongly suggest that you clean up any local obsolete libraries from your HOME:
- /home/ap/texmf/tex/french
- /home/ap/texmf/tex/latex/frenchle
to avoid weird behaviour.

Loading...