Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56207 - [linux-lts/linux] libinput 1.9.1-1 No input is possible via PS2-keyboard

Attached to Project: Arch Linux
Opened by bernie (bernie) - Thursday, 02 November 2017, 18:04 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 18 November 2017, 17:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andreas Radke (AndyRTR)
Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Dear ArchLinux-Team,

I have upgraded to libinput 1.9.1-1 . But after the restart my PS/2 connected keyboard is not working with linux-lts 4.9.59-1 anymore, but with linux 4.13.10-1.
=> No input is possible via PS2-keyboard.
The keyboard is detected as you can see in the attached logs. Replug does not help. The mouse via usb works.
When I use a USB keyboard there is no problem.

Downgrading to libinput 1.8.3-1 helps.

faulty version: libinput 1.9.1-1

last working: libinput 1.8.3-1 with linux-lts and linux kernel

But libinput 1.9.1-1 has no problem with linux 4.13.10-1 , only with linux-lts 4.9.x

Using: sddm 0.16.0-1

00-keyboard.conf
# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbVariant" "nodeadkeys"
EndSection

I cannot find any relevant error/warning message in the system log or Xorg.log.


Steps to reproduce:
Install libinput 1.9.1-1
Restart and use the linux-lts kernel with a PS2 keyboard.
=> No input via keyboard is possible.

Best regards, bernie


Additional info:
* config and/or log files etc.

libinput list-devices # - libinput 1.9.1-1

Device: AT Translated Set 2 keyboard
Kernel: /dev/input/event0
Group: 6
Seat: seat0, default
Capabilities: keyboard
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: n/a
Nat.scrolling: n/a
Middle emulation: n/a
Calibration: n/a
Scroll methods: none
Click methods: none
Disable-w-typing: n/a
Accel profiles: n/a
Rotation: n/a

libinput list-devices - libinput 1.8.3-1

Device: AT Translated Set 2 keyboard
Kernel: /dev/input/event0
Group: 5
Seat: seat0, default
Capabilities: keyboard
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: n/a
Nat.scrolling: n/a
Middle emulation: n/a
Calibration: n/a
Scroll methods: none
Click methods: none
Disable-w-typing: n/a
Accel profiles: n/a
Rotation: n/a


/tmpdir/system/working-xorg.log:[ 69.101] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
/tmpdir/system/working-xorg.log:[ 69.101] (**) Option "Device" "/dev/input/event0"
/tmpdir/system/working-xorg.log:[ 69.101] (II) event0 - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
/tmpdir/system/working-xorg.log:[ 69.101] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
/tmpdir/system/working-xorg.log:[ 69.101] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device removed
/tmpdir/system/working-xorg.log:[ 69.140] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
/tmpdir/system/working-xorg.log:[ 69.140] (II) event0 - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
/tmpdir/system/working-xorg.log:[ 69.140] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
/tmpdir/system/working-xorg.log:[ 69.410] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device removed
/tmpdir/system/faulty-xorg.log:[ 9.861] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
/tmpdir/system/faulty-xorg.log:[ 9.861] (**) Option "Device" "/dev/input/event0"
/tmpdir/system/faulty-xorg.log:[ 9.861] (II) event0 - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
/tmpdir/system/faulty-xorg.log:[ 9.861] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
/tmpdir/system/faulty-xorg.log:[ 9.861] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device removed
/tmpdir/system/faulty-xorg.log:[ 9.900] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
/tmpdir/system/faulty-xorg.log:[ 9.900] (II) event0 - (II) AT Translated Set 2 keyboard: (II) is tagged by udev as: Keyboard
/tmpdir/system/faulty-xorg.log:[ 9.900] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device is a keyboard
/tmpdir/system/faulty-xorg.log:[ 34.970] (II) event0 - (II) AT Translated Set 2 keyboard: (II) device removed


xinput list # - libinput 1.9.1-1
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=9 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=10 [slave pointer (2)]
⎜ ↳ Microsoft Comfort Curve Keyboard 2000 id=17 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=8 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=11 [slave keyboard (3)]
↳ HP WMI hotkeys id=12 [slave keyboard (3)]
↳ i2c IR (Hauppauge) id=13 [slave keyboard (3)]
↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=14 [slave keyboard (3)]
↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=15 [slave keyboard (3)]
↳ Microsoft Comfort Curve Keyboard 2000 id=16 [slave keyboard (3)]
↳ Microsoft Comfort Curve Keyboard 2000 id=18 [slave keyboard (3)]

xinput list # - libinput 1.8.3-1
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=11 [slave pointer (2)]
⎜ ↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=12 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=10 [slave keyboard (3)]
↳ AT Translated Set 2 keyboard id=13 [slave keyboard (3)]
↳ HP WMI hotkeys id=14 [slave keyboard (3)]
↳ i2c IR (Hauppauge) id=15 [slave keyboard (3)]
↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=17 [slave keyboard (3)]
↳ Microsoft Microsoft® 2.4GHz Transceiver v6.0 id=18 [slave keyboard (3)]


xinput list-props 11 # - libinput 1.9.1-1
Device 'AT Translated Set 2 keyboard':
Device Enabled (139): 1
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Send Events Modes Available (262): 1, 0
libinput Send Events Mode Enabled (263): 0, 0
libinput Send Events Mode Enabled Default (264): 0, 0
Device Node (265): "/dev/input/event0"
Device Product ID (266): 1, 1

xinput list-props 13 # - libinput 1.8.3-1

Device 'AT Translated Set 2 keyboard':
Device Enabled (139): 1
Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Send Events Modes Available (262): 1, 0
libinput Send Events Mode Enabled (263): 0, 0
libinput Send Events Mode Enabled Default (264): 0, 0
Device Node (265): "/dev/input/event0"
Device Product ID (266): 1, 1

grep -e "Using input driver 'libinput'" /var/log/Xorg.0.log
[ 9.624] (II) Using input driver 'libinput' for 'Power Button'
[ 9.706] (II) Using input driver 'libinput' for 'Power Button'
[ 9.744] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v6.0'
[ 9.781] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v6.0'
[ 9.822] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v6.0'
[ 9.861] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[ 9.901] (II) Using input driver 'libinput' for 'HP WMI hotkeys'
[ 10.001] (II) Using input driver 'libinput' for 'i2c IR (Hauppauge)'
[ 10.045] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v6.0'
[ 10.046] (II) Using input driver 'libinput' for 'Microsoft Microsoft® 2.4GHz Transceiver v6.0'
[ 20.036] (II) Using input driver 'libinput' for 'Microsoft Comfort Curve Keyboard 2000'
[ 20.082] (II) Using input driver 'libinput' for 'Microsoft Comfort Curve Keyboard 2000'
[ 20.121] (II) Using input driver 'libinput' for 'Microsoft Comfort Curve Keyboard 2000'
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 18 November 2017, 17:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux-lts 4.9.62-1
Comment by Andreas Radke (AndyRTR) - Thursday, 02 November 2017, 19:39 GMT Comment by naraesk (naraesk) - Thursday, 02 November 2017, 21:38 GMT
In the forum many users reported the same issue, especially when using a HP Laptop in combination with a docking station: https://bbs.archlinux.org/viewtopic.php?pid=1746774#p1746774
Comment by Kristian Rink (kawazu428) - Friday, 03 November 2017, 08:12 GMT
Same here - I posted this message in antergos forum yesterday (https://forum.antergos.com/topic/8344/antergos-17-10-new-install-keyboard-not-working-in-login-screen). HP laptop, built-in keyboard is not working with libinput 1.9.1. External keyboard (USB) works, however. I'm not using wayland as far as I can tell.
Comment by Andreas Radke (AndyRTR) - Friday, 03 November 2017, 14:08 GMT
Posting to forums won't help. Report it upstream so Peter is aware of it and can nail it down and fix it.
Comment by Kristian Rink (kawazu428) - Friday, 03 November 2017, 14:17 GMT Comment by bernie (bernie) - Friday, 03 November 2017, 17:04 GMT
I have added my notes to the freedesktop-bugreport too.
Comment by bernie (bernie) - Saturday, 04 November 2017, 07:45 GMT
It seems to be HP related: my desktop PC is also a HP.

Workaround on Arch Linux: Either downgrade to libinput 1.8.3 or blacklist module hp_wmi .
Comment by Philip Müller (philm) - Wednesday, 08 November 2017, 22:28 GMT Comment by Andreas Radke (AndyRTR) - Thursday, 09 November 2017, 06:43 GMT
Please someone affected confirm that applying this patch is the fix.
Comment by Philip Müller (philm) - Thursday, 09 November 2017, 11:01 GMT Comment by Philip Müller (philm) - Friday, 10 November 2017, 12:24 GMT
Greg is now queueing them up for the next kernel point releases ...
Comment by Andreas Radke (AndyRTR) - Wednesday, 15 November 2017, 16:45 GMT
These commits are now included in 4.9.62 lts kernel.

From the upstream report one commit is required on top of latest 4.13/4.14 kernels to get also some convertible devices working:
http://git.infradead.org/users/dvhart/linux-platform-drivers-x86.git/commit/9968e12a291e639dd51d1218b694d440b22a917f

Also asigning the bug to our stock kernel maintainers to add that commit there. The commit requires major hp-wmi changes done after 4.9 release that are not considered simple stable fixes to be backported to 4.9 LTS branch. These devices will remain broken in 4.9 and won't get fixed there. Please use the stock or a custom kernel with that commit until it ends in the Linus tree and gets released.
Comment by loqs (loqs) - Wednesday, 15 November 2017, 17:53 GMT
If the linux kernel packages are going to take none upstreamed patches should the same not apply to  FS#55803 ?
Comment by bernie (bernie) - Thursday, 16 November 2017, 18:58 GMT
My problem is fixed with linux-lts 4.9.62-1 . The PS2-keyboard is working with kernel module hp_wmi and linux-lts.

Thanks.

Loading...