Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56202 - [pstoedit] Latex rendering broken in inkscape with ghostscript 9.22-1

Attached to Project: Arch Linux
Opened by Nick (aristocrates) - Thursday, 02 November 2017, 07:56 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 18:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: When attempting to add a Latex equation to a project in inkscape, an error occurs and no output is produced.


Additional info:
* package versions: inkscape-0.92.2-5, ghostscript-9.22-1

Steps to reproduce:
1. Install inkscape
2. Install dependencies to enable the Extensions -> Render -> LaTeX menu (pstoedit and ghostscript)
3. Ensure that ghostscript is at version 9.22-1
4. Open inkscape, click on menu Extensions -> Render -> LaTeX...
5. Attempt to render Latex code (i.e. type $\tau$ and click Apply)

Workaround:
Downgrading to ghostscript-9.21-3 fixes the issue

Error message (in popup):
*** WARNING - the DELAYBIND command has been deprecated, and will be

removed in the next version. For now you can restore

the behaviour by using -dREALLYDEALYBIND but if you

require continued use of this command you should contact

the Ghostscript developers. Commercial customers of

Artifex should email their support contact, free users

are encouraged to talk to us on the #ghostscript IRC

channel on irc.freenode.net.

Unrecoverable error: undefined in DELAYBIND

PostScript/PDF Interpreter finished. Return status 65280 executed command : /usr/bin/gs -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS "/tmp/psinSiRV2Q"

The interpreter seems to have failed, cannot proceed !

Traceback (most recent call last):
File "eqtexsvg.py", line 160, in <module>
e.affect()
File "/usr/share/inkscape/extensions/inkex.py", line 283, in affect
self.effect()
File "eqtexsvg.py", line 154, in effect
svg_open(self, svg_file)
File "eqtexsvg.py", line 81, in svg_open
doc = inkex.etree.parse(filename)
File "src/lxml/etree.pyx", line 3444, in lxml.etree.parse (src/lxml/etree.c:83170)
File "src/lxml/parser.pxi", line 1834, in lxml.etree._parseDocument (src/lxml/etree.c:120742)
File "src/lxml/parser.pxi", line 1860, in lxml.etree._parseDocumentFromURL (src/lxml/etree.c:121089)
File "src/lxml/parser.pxi", line 1764, in lxml.etree._parseDocFromFile (src/lxml/etree.c:119997)
File "src/lxml/parser.pxi", line 1161, in lxml.etree._BaseParser._parseDocFromFile (src/lxml/etree.c:114546)
File "src/lxml/parser.pxi", line 598, in lxml.etree._ParserContext._handleParseResultDoc (src/lxml/etree.c:107723)
File "src/lxml/parser.pxi", line 709, in lxml.etree._handleParseResult (src/lxml/etree.c:109432)
File "src/lxml/parser.pxi", line 638, in lxml.etree._raiseParseError (src/lxml/etree.c:108286)
File "/tmp/inkscape-XKs3ng/eq.svg", line 1
lxml.etree.XMLSyntaxError: Document is empty, line 1, column 1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 21 March 2018, 18:56 GMT
Reason for closing:  Upstream
Comment by Nick (aristocrates) - Saturday, 04 November 2017, 05:03 GMT
In ghostscript-9.22-1, the -dDELAYBIND flag has been deprecated, and the use of this flag will result in an error; because inkscape uses pstoedit to implement Latex input, and because pstoedit calls Ghostscript with the -dDELAYBIND flag, this error prevents Latex text from being rendered in inkscape through the Extensions -> Render -> LaTeX.
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 13:13 GMT
I've send a mail to the pstoedit dev asking for his statement here.
Comment by Andreas Radke (AndyRTR) - Wednesday, 21 March 2018, 18:56 GMT
pstoedit dev pointed to this fix that will be included in the next ghostscript release:
http://git.ghostscript.com/?p=ghostpdl.git;a=patch;h=fa499a5809aab45b2891b5c8b2363d1bca890757

pstoedit will need tweaks though.

Loading...