Release Engineering

This project is intented for all release related issues (isos, installer, etc), under the umbrella of the ArchLinux Release Engineers
Tasklist

FS#56173 - [archiso] ISO creation are busted because of util-linux / rfkill conflict.

Attached to Project: Release Engineering
Opened by Frederic Bezies (fredbezies) - Monday, 30 October 2017, 21:29 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Wednesday, 01 November 2017, 22:38 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To Pierre Schmitz (Pierre)
Gerardo Exequiel Pozzi (djgera)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I wanted to create an updated ISO for a project I'm working on. I used archiso script, and it crashes because of util-linux / rfkill conflict introduced in last util-linux update.

I got this message :

looking for conflicting packages...
:: rfkill and util-linux are in conflict. Remove util-linux? [y/N]
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: rfkill and util-linux are in conflict
==> ERROR: Failed to install packages to new root

Additional info:
util-linux 2.31-1
archiso 32-1

Steps to reproduce:

Just update your system and try to generate an ISO...
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Wednesday, 01 November 2017, 22:38 GMT
Reason for closing:  Fixed
Additional comments about closing:  v33
Comment by Frederic Bezies (fredbezies) - Tuesday, 31 October 2017, 09:29 GMT
Some more infos. It crashes right after system user creation.

Longer log attached.
Comment by Frederic Bezies (fredbezies) - Tuesday, 31 October 2017, 09:35 GMT
Removing rfkill from configs/releng/packages.both helped. I get a fresh new ISO after tweaking packages.both file.

Loading...