Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56172 - [gdm] gdm 3.26.2 fails to create session on startup

Attached to Project: Arch Linux
Opened by Leopold Bloom (leopoldbloom) - Monday, 30 October 2017, 21:26 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 31 October 2017, 19:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 50
Private No

Details

Description:
After upgrading to gdm 3.26.2 and restarting, the gdm fails to create a backend and launch the X server. It appears as if there is some kind of incompatibility between this version of GDM and the GNOME components it is supposed to launch. The relevant log entries are attached.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 31 October 2017, 19:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  gdm 3.26.2.1-1
Comment by Britt Yazel (brittyazel) - Monday, 30 October 2017, 23:11 GMT
I too have this exact issue using the Nvidia proprietary drivers. Rolling back to 3.26.1 fixes this temporarily
Comment by Jonathan Nicholson (jonnich) - Tuesday, 31 October 2017, 01:29 GMT
I also had this issue and downgraded back to 3.26.1.
Comment by Steve Bennet (mh272) - Tuesday, 31 October 2017, 02:00 GMT
This happened to me too, but with Wayland. When trying to login, it kicked me back to the login screen (gdm).
Gnome-Xorg works fine. But, when I select Gnome-Xorg, on next reboot, Gnome is selected.
Downgrading back to 3.26.1 and everything is ok.
Comment by Stephen Ellis (f1na1b055) - Tuesday, 31 October 2017, 06:21 GMT
Happened to me as well, downgraded to 3.26.1 after loading lxdm to confirm it was gdm.
Comment by Ralph Plawetzki (Ralph) - Tuesday, 31 October 2017, 06:45 GMT
In my case with Wayland after upgrading from 3.26.1 to 3.26.2 gives me the following errors and the UI does not come up

-- Reboot --
Okt 31 06:51:56 six kernel: acer_wmi: Unsupported machine has AMW0_GUID1, unable to load
Okt 31 06:51:59 six gnome-session-binary[460]: Unrecoverable failure in required component org.gnome.Shell.desktop
Okt 31 06:51:59 six gdm[416]: GLib: g_variant_new_string: assertion 'string != NULL' failed
Okt 31 06:51:59 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.Shell.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Wacom.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.XSettings.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.A11yKeyboard.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Clipboard.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Color.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Keyboard.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.MediaKeys.desktop
Okt 31 06:52:00 six gnome-session-binary[546]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Power.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.Shell.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Wacom.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.XSettings.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.A11yKeyboard.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Clipboard.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Color.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Keyboard.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.MediaKeys.desktop
Okt 31 06:52:00 six gnome-session-binary[641]: Unrecoverable failure in required component org.gnome.SettingsDaemon.Power.desktop
.
.
.

Attached you can find the output of journalctl -o verbose MESSAGE="Unrecoverable failure in required component org.gnome.Shell.desktop" --since "2017-10-31 06:00:00"
Comment by Gerhard Bogner (slashME) - Tuesday, 31 October 2017, 07:52 GMT
Same problem here.
Comment by Ladislav Ezr (Redi) - Tuesday, 31 October 2017, 08:27 GMT
Can confirm. I have the WaylandEnable=false option uncommented.
Comment by eaut (eaut) - Tuesday, 31 October 2017, 09:26 GMT
confirmed, same here
Comment by Timo Saarinen (timosa) - Tuesday, 31 October 2017, 10:01 GMT
and here too... downgrading gdm and libgdm to 3.26.1 is a workaround
Comment by Leonidas Spyropoulos (inglor) - Tuesday, 31 October 2017, 10:15 GMT
No need to comment - just Vote (and watch) if you are affected.
Comment by Peter Vágner (pvagner) - Tuesday, 31 October 2017, 11:00 GMT
I would say nvidia proprietary driver update even further complicates this issue. Logs are attached.
On my system I have to downgrade 4 packages in order to restore X working.
gdm-3.26.1-1
libgdm-3.26.1-1
nvidia-387.12-2
nvidia-387.12-2
I am running nvidia optimus powered laptop Asus K53. Wayland is intentionally disabled on both GDM and Gnome shell because of accessibility issues with Gnome on Wayland (such as https://bugzilla.gnome.org/show_bug.cgi?id=709999).
Edit: nvidia-387.22-3 is working fine as others have pointed out. So the gdm related issue remains on my system.
Comment by Xinyun Zhou (xinsnake) - Tuesday, 31 October 2017, 11:19 GMT
On my machine it works with the following versions:

- local/gdm 3.26.1-1 (gnome)
- local/libgdm 3.26.2-1
- local/nvidia 387.22-3
- local/nvidia-settings 387.12-1
- local/nvidia-utils 387.22-1

If I upgrade gdm to 3.26.2-1 it will break.
Comment by Ramon L. Panades (Panadestein) - Tuesday, 31 October 2017, 12:19 GMT
Just to confirm: upgrading libgdm (3.26.1-1 -> 3.26.2-1) and gdm (3.26.1-1 -> 3.26.2-1) brakes my system. In this case, I'm not using the proprietary Nvidia driver, but the open source nouveau. Using the Xorg or Wayland backed of GDM ended in a frozen system. Downgrading gdm and libgdm did fixed the issue.

Edit: Only need to downgrade gdm (3.26.1-1 -> 3.26.2-1), and stick with libgdm 3.26.2-1, to fix the issue.
Comment by Max Liebkies (gegenschall) - Tuesday, 31 October 2017, 14:53 GMT
Same here. I have WaylandEnable=true uncommented and am using the proprietary nvidia driver. No GDM for me, downgrade solves this however.
Comment by Daniel Bartlau (Bluesman) - Tuesday, 31 October 2017, 15:45 GMT
Happened to me here as well after the upgrate to the new GDM version.

- X11 with nvidia-driver and Wayland disabled

Downgrade of gdm and libgdm solves the problem. Had to restart the system by crossing the fingers and do the magic SysReq.


Comment by Jan Alexander Steffens (heftig) - Tuesday, 31 October 2017, 16:12 GMT
Can we get the journal log of a failed login with Enable=true in the [debug] section of /etc/gdm/custom.conf ?
Comment by Rodrigo Pontes (RoDeLoPo) - Tuesday, 31 October 2017, 16:15 GMT
Same here. Had to downgrade to GDM 3.26.1-1. Using proprietary NVIDIA drivers.
Comment by Max Liebkies (gegenschall) - Tuesday, 31 October 2017, 16:26 GMT
@heftig: Sure, here you go.

edit: Sorry, misread your request for debug enabled log. Please disregard this comment. :/
   log (204 KiB)
Comment by Arseniy Ivin (arssivka) - Tuesday, 31 October 2017, 16:40 GMT
Resent nvidia (to 387.22-1) and gdm (to 3.26.2-1) package update broke down gnome shell desktop. System freezes when systemd starts gdm service. We were able to reproduce this bug on machine with same hardware. Journalcrl shows a lot of error messages with "Unrecoverable failure in required component org.gnome...". Downgrading nvidia to 387.12-2, nvidia-utils to 387.12-1 and gdm to 3.26.1-1 repairs gnome shell. I have also tried downgrade gdm package with new nvidia drivers and downgrade nvidia with new gdm but it didn't help.
Comment by Peter Vágner (pvagner) - Tuesday, 31 October 2017, 16:42 GMT
@gegenschall It appears gdm debug was not enabled when you tried to repro...
Here is mine however I've only included gdm messages.
I guess gdm is trying to force wayland session here, I have no wayland session configured thus it exits with an error. Should I provide full log instead?

@arssivka nvidia-387.22-3 fixes the nvidia related brokennes however gdm failure still remains to be an issue.
   gdm.log (42.4 KiB)
Comment by Jan Alexander Steffens (heftig) - Tuesday, 31 October 2017, 16:42 GMT
Also, please test this build and report back:

https://pkgbuild.com/~heftig/gdm/

Install both packages.
Comment by Phillip Bartschinski (gorden) - Tuesday, 31 October 2017, 16:44 GMT
The same error log here but with AMD drivers

extra/gdm 3.26.2-1 (gnome)
extra/libgdm 3.26.2-1
mesa-git/xf86-video-amdgpu-git 352.f6b39bc-1 (xorg-drivers)

Workaround Downgrading to
extra/gdm 3.26.1-1 (gnome)

Update the 2 pakages from https://pkgbuild.com/~heftig/gdm/ is working for me
extra/gdm 3.26.2-1.1 (gnome)
extra/libgdm 3.26.2-1.1
Comment by Peter Vágner (pvagner) - Tuesday, 31 October 2017, 16:54 GMT
3.26.2-1.1 packages are also working fine for me.
   gdm.log (42.4 KiB)
Comment by Jan Alexander Steffens (heftig) - Tuesday, 31 October 2017, 17:11 GMT
Thanks. Unfortunately, the truncated gdm-service-only logs aren't enough; the interesting things happen in the session processes.
Comment by Kerr (zefkerrigan) - Tuesday, 31 October 2017, 17:14 GMT
I have the same problem. Only the GNOME Xorg session works. GNOME Wayland does not work anymore.
I have:
$ lspci -k | grep -i -A 2 -E "(display|vga|3d)"
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X]
Subsystem: Gigabyte Technology Co., Ltd Cape Verde XT [Radeon HD 7770/8760 / R7 250X]
Kernel driver in use: amdgpu
With Mesa, not AMDGPU-PRO.
Comment by Jan Alexander Steffens (heftig) - Tuesday, 31 October 2017, 17:22 GMT Comment by Daniel Bartlau (Bluesman) - Tuesday, 31 October 2017, 17:26 GMT
I have made a new run to gather information in the debug mode.

Comment by Jan Alexander Steffens (heftig) - Tuesday, 31 October 2017, 17:43 GMT
Should be fixed in 3.26.2.1-1
Comment by eaut (eaut) - Tuesday, 31 October 2017, 19:09 GMT
3.26.2.1-1 works for me! thanks
Comment by eaut (eaut) - Tuesday, 31 October 2017, 19:09 GMT
3.26.2.1-1 works for me! thanks
Comment by Steve Bennet (mh272) - Tuesday, 31 October 2017, 19:55 GMT
Just wanted to say thanks for the fix! :)

Loading...