Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#56158 - Firefox - Incorrect user agent on FF 56

Attached to Project: Arch Linux
Opened by Nate (ion203) - Monday, 30 October 2017, 01:57 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 30 October 2017, 02:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
My FF56 user agent is: "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0"

Expected user agent: "Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0"

Note the end where it incorrectly identifies itself as 50.0 rather than 56. This does not happen when I download FF 56 from mozilla.org and extract/run the binary from there, getting the expected user agent.

Additional info:
Name : firefox
Version : 56.0.2-1
Architecture : x86_64paca

This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 30 October 2017, 02:38 GMT
Reason for closing:  Not a bug
Additional comments about closing:  op request: "My mistake, this appears to have been a profile issue."

Loading...